The process of generating an image from a model.

learn more… | top users | synonyms

0
votes
0answers
43 views

Problem on displaying a layer in overlay on a s57 map

I am loading a s57 file, I select only some layer to be displayed. I am under QGIs 2.8 At this point it is ok, the coordinatereferencesystem is EPSG4326 WGS84 and at the bottom of the windows of qgis ...
0
votes
1answer
480 views

How to optimise rendering of layer-groups in Geoserver

I am running GeoServer 2.8 on Ubuntu 14 as a WAR in Tomcat 7. I have an 8 core machine with 16GB of RAM and have allowed a generous Heap size of 4GB. I have JAI installed and enabled. Meta tiling ...
0
votes
0answers
25 views

Problem with VectorLayer created in memory

I am working in c++/QT whithnthe qgis API c++ I had to build a personnalized vectorlayout called "TRACKS" , so i write a function that create in memory the vectorlayer like this : QgsVectorLayer *...
0
votes
0answers
59 views

Need help on how to move a symbol over a map

I'm working in c++/qt and the c++ api qgis 2.8.2 In my application i load a map with a s57 file, this part works perfectly, now i need to make some plot representing different object like boat, plane, ...
0
votes
0answers
313 views

Rendering Problem: OpenStreetMap Server CentOS 7

The Problem I'm trying to install an OpenStreetMap server on CentOS 7. I'm using mapnik 2.2.0 and PostGis 2.0. When I try to render the tiles for the server I get the following error: renderd[10581]:...
0
votes
0answers
15 views

How can I extract the latitude and longitude from a s57 File [duplicate]

I had to extract the longitude and latitude from a s57 file, in order to superpose a satelite view from the same point. These coordinate will allow me to get the exact position on google map by ...
0
votes
0answers
55 views

Compiling mod_tile problem

I wanted to build my own tile server as written on switch2osm site. In short: render is not happening (more details you can find here). Seems that mod_tile is not installed correctly. First it gave ...
3
votes
2answers
144 views

How to create a dashed polygon border in C++?

In my maps I have a symbol, his type is polygon, I want to change the line style of the border, actually is solid , I had to put it in dash Is there a simple way to change it ? i think to the ...
1
vote
1answer
132 views

Rendering of SVG for layer symbols using QGIS?

I have a little problem with the rendering of SVG for layer symbol. I want to creeate a categorized symbol to show different style of buoy I have for that two icons the first is an half circle filled,...
0
votes
0answers
19 views

Problem on rendering categorizedSymbolRendererV2

Finally my code works but the renderering display just one color instead of 4 I don't know why, I follow the sample code of the snorf.net website and the sample code in the qgis python programming ...
1
vote
0answers
162 views

GeoSever PointStacker Renders incorrect position

I've been trying the GeoServer Rendering Transformations - Point Stacker. According to this docs there's an optional cellSize parameter for setting the "Size of the cells in which to aggregate points, ...
1
vote
0answers
170 views

How to wait for mapCanvas render before taking a screenshot?

i am trying to iterate over a large list of features and making a screenshot of the selected feature. My problem is that it seems to be a delay between the refreshing of the canvas and the taking of ...
1
vote
1answer
965 views

Map Not rendered Leaflet but renders correctly in changing the zoom level of browser

I am loading a leaflet map rendering mapbox tiles, geojson layers (initially i dont show the map) and i also have tabular links which can be seen when the page loads, the links are list of places and ...
0
votes
1answer
558 views

renderd not rendering

I followed the instructions manually building a tile server and ran in some problems. When entering http://localhost:8080/osm_tiles/0/0/0.png renderd shows this: renderd[263]: DEBUG: Got incoming ...
0
votes
1answer
284 views

How to solve rendering in arcscene?

Is there some way to "repair" rendering in ArcScene? As you can see on the picture some of the polygons are not rendered correctly it's probably because polygons are overlapping each other. In arcmap ...
2
votes
1answer
481 views

Max Zoom Level in Mapnik

A question regarding mapnik: Is it possible to configure a custom max. zoom level? I am trying to find a way to get mapnik to render tiles for zoom levels 20+ (till 28 would be nice). PS: The ...
1
vote
1answer
117 views

QgsComposerMap does not fit extent

Please help me to fit the map extent into de qgscomposermap size. printable_layers = QgsMapLayerRegistry.instance().mapLayers().values() printable_layers_ids = [] ...
0
votes
1answer
31 views

Improving Global Scene transition when changing location using bookmarks in ArcGIS Pro?

Using ArcGIS Pro 1.0.0 I have: Created a new project using Global Scene.aptx Switched the Basemap to National Geographic Navigated to and created Bookmarks for some countries of different sizes: ...
0
votes
1answer
261 views

How to convert citygml fo KML?

I am trying to render citygml files. I am using NWW for rendering purpose. I have used citygml4j library to extract the GroundSurface, roof, and walls geometry, and was able to render them. But due to ...
3
votes
3answers
250 views

GeoJSON Rendering in Leaflet

I have published a wms using the QGIS Cloud and on top of it I am overlaying the same data (countries of Europe), using GeoJSON. Have a look at an example here: http://jsfiddle.net/j21kh7ao/ At a low ...
0
votes
1answer
50 views

Rendering thumbnails of a GPX track with my own tiles as base layer

I created my own Map using Tilemill. Now I'd like to display thumbnails of a GPX track where my map is the base layer. Do you have any idea how to do this performantly? I wrote a script that does it ...
1
vote
0answers
207 views

How to create 3D globe images highlighting a specific country or 2D country map with capital?

I am building an Anki flashcard set that should contain country flags, names and (ideally) a 3D globe with the country outlined, as can be seen on Wikipedia. I've already completed the part that ...
0
votes
0answers
97 views

In OpenLayers, the strokeDashstyle property does not work in WFS when the renderer is Canvas

I have a wfs layer, i.e. a vector layer with wms data on in. I want to be able to apply the strokeDashstyle property on the features. Somehow this only works when I disable the Canvas renderer, i.e., ...
2
votes
1answer
155 views

How to suppress polygon boundaries shared by objects of same type in QGIS?

Given polygons - like landcover in OpenStreetMap or street areas in cadastre - how can one suppress those polygon boundaries which are shared by objects (features) of same type in QGIS (see figure ...
0
votes
0answers
24 views

Refreshing QGIS view [duplicate]

I've written a short python script for use in QGIS (currently using 2.8.1) to set the CRS for all loaded layers to OSGB 1936 / BNG. The script correctly sets the CRS but I have to manually scroll in/...
0
votes
0answers
33 views

Make geoserver to send the WMS request when the user is idle for some seconds

I see in the geoserver admin page that there are three difference methods for Raster Rendering (bilinear, bicubic and nearest neighbour). Loading my WMS layers using openlayers and then zooming and ...
1
vote
1answer
451 views

OpenLayers measure map rendering time

I am using OpenLayers version 3 (answers with ver 2 are also OK) and want to measure how long it takes to render the vector layer. So, I have a vector layer with features: var vectorLayer = new ol....
1
vote
1answer
651 views

Firefox and D3: Zoom + Pan bug

I have a simple code here some map with zoom+pan effect. It work fine on Opera, Chrome even IE. But Firefox do not show it.- If you open "Inspector" panel, you'll see has same values (translation, ...
0
votes
1answer
202 views

Planet or regions offline maps between two zoom levels

I need offline maps to be included in the application I am developing. I decided to use marble https :// marble.kde.org/ to do this. Marble uses openstreetmap tileserver (among others). What I need ...
2
votes
1answer
711 views

How to save the Map Canvas as PNG with transparent background programmatically?

I wrote a script to create a big number of heatmaps for a given scenario. I would like to save the result of every heatmap as a png image. I have figuered it out doing it with simple Map Rendering but ...
3
votes
1answer
131 views

What is the replacement for 'setColorShadingAlgorithm' in QGIS 2.6?

I have been struggling with setting the colorshadingalgorithm for a raster layer in QGIS with no success for the past few days. The QGIS cookbook seems to be pretty outdated. Anyways, the code that I ...
0
votes
1answer
161 views

Dynamic rendering on a layer with a long SQL query

I have a question on dynamic rendering with the cartodb APIs. These APIs are new for me. Data is a big layer stored in cartoDB (about 30 000 polygons). In my application the default rendering of ...
1
vote
0answers
111 views

Displaying a Digitial Elevation Model using GRASS GIS draped by an RGB Raster

I have the following: Digital Elevation Model from SRTM LANDSAT Imagery from the same area I wish to display the DEM draped with the raster band combination (3,2,1) using GRASS GIS. My ...
5
votes
4answers
2k views

Shapefile layers in QGIS don't display unless I zoom out

I have two shapefile layers in a Qgis project that have problems with zooming. One is a line I copied/pasted in a new layer from a set of height contours and the other one is a polygon layer I created ...
1
vote
1answer
328 views

OSM Tiles slow at low zoom levels

We have built an OSM Tile Server following the instructions at http://switch2osm.org/serving-tiles/building-a-tile-server-from-packages/ We have imported planet_latest.osm.pbf. Our server renders ...
0
votes
0answers
794 views

OSM Tile Server: How to avoid 404 errors?

We have built a OSM tile server with the following hardware Make: Dell Model: PowerEdge T110II RAM: 16GB HDD: 1TB RAID 1 using the excellent instructions provided by http://switch2osm.org/serving-...
1
vote
1answer
120 views

Unable to find either renderd.py or generate_tiles.py

We created a Ubuntu 14.04.1 LTS x64 OSM tile server from packages using the excellent instructions provided by http://switch2osm.org/serving-tiles/building-a-tile-server-from-packages/ The tile ...
0
votes
2answers
2k views

openlayers 3 ol3 - how to redraw a single feature

I would like to be able to trigger rerendering of a single feature after a user has clicked on it. (I can catch the click and update the metadata that feeds the styling function, but I am then forced ...
3
votes
3answers
458 views

Rendering local osm files android dev

I'm development an android app for navigate inside the university campus, it's my graduation project :). I did the campus map with Josm, now I have it in .osm I found many libraries and frameworks ...
0
votes
1answer
267 views

error while starting render on startup

i have configured a tile server by following the switch2osm in the last step for starting the render automatically on startup if i start the render as below vars.sh is missing $ sudo /etc/init.d/...
1
vote
1answer
70 views

Geoserver strange inverse polygon rendering

I found strange behaviour of rendering one particular polygon on Geoserver. Red polygon in the link. If you compare SHP data from ZIP file in some desktop software like QGIS and rendering from ...
1
vote
0answers
104 views

Geoserver does not render polygon properly

I am trying to a get polygon layer from CSV file. I chose to do it via rasterization and polygonization in QGIS, howerver, Geoserver has problems to correctly render some polygons. This is how the ...
1
vote
0answers
102 views

QGIS Atlas web layer rendering - how can I slow it down?

I cannot get Atlas to export maps with web layers correctly. When I look at the preview within composer everything works fine. When I export an atlas the first page renders ok but for subsequent ...
3
votes
0answers
136 views

arcpy.mapping.ExportToTIFF fails to render layer?

Has anyone else had this problem? I have an mxd file with two layers in it, one of which is fairly 'heavy' (i.e. takes a minute or so to draw). All layers are visible by default. I have the ...
1
vote
3answers
68 views

Tilemill didn't render streets correctly, some parts are missing

can someone please explain me what's happend in the picture below or how i can debug what's going wrong? I downloaded some .osm.pbf files imported the files via osm2pgsql into a postgis database and ...
1
vote
0answers
194 views

Rendering process failed null

I published a polygon shape file with default polygon sld , while in preview when I click on feature it shows the error rendering process failed null.Please explain what is this error, what i have yo ...
1
vote
0answers
24 views

How to know which Tiles build a rendered Image obtained by a Map Query?

as Test Purpose for my app, I want to know exactly, which Tiles were used to render the result image I get by query. I.e. I want to see a bounding box of 500px*300px with zoom 13 of Location 48.42,12....
5
votes
2answers
120 views

QGIS renders outlines where none should be

QGIS always renders the borders of a feature polygon. How can I disable this? Even if I set Border style to "No Pen" and the colour is exactly the same for different categories there is a small grey ...
3
votes
1answer
177 views

Problems while rendering with Atlas

when I export my data genereated with the openLayers using Atlas rendering is always incomplete. Atlas is rendering too fast so that the data from openLayers is not completely loaded. Do anyone ...
3
votes
1answer
210 views

OpenLayers.Renderer.Symbols custom named by function

Is there any approach to define custom OpenLayers.Renderer.symbol by a function? For example, instead of making a symbol for each 3-pointed, 4-pointed, 5-pointed etc. star OpenLayers.Renderer....