Ubuntu is a computer operating system based on the Debian Linux distribution and distributed as free and open source software, using its own desktop environment.

learn more… | top users | synonyms

1
vote
0answers
25 views

Can I have two distinct workspaces with two different layers reference the same data store in Geoserver?

Using geoserver 2.7.2 on Ubuntu 14.04 64 bit. I have a large image pyramid I'd like to use in two workspaces simultaneously. Do I have to create two separate "stacks" of folders, stores, and layers?...
4
votes
1answer
135 views

GRASS 6.4 Reinstallation for Ubuntu

I need to reinstall GRASS 6.4 on this Ubuntu computer due to compatibility issues. I had installed GRASS 6.4 a few weeks ago to work with a simulation program. I used the command apt-get install ...
0
votes
0answers
44 views

Intalling and Mapserver and MapCache on Ubuntu 12.04

I want to install mapserver with mapcache on ubuntu 12.04 as cgi. I tried sudo apt-get install mapserver-bin, but I'm receiving the following error: The following packages have unmet dependencies: ...
2
votes
1answer
711 views

QGIS 2.12 & Ubuntu 14.04 SAGA installation not found

Installing QGIS 2.12 on Ubuntu 14.04 from the debian trusty ppa. Upon opening QGIS I notice the following error under the Processing tab: Problem with SAGA installation: SAGA was not found or is not ...
1
vote
0answers
27 views

“SSL Errors Occurred Accessing URL” after upgrade to Lyon

I just upgraded to QGIS Lyon in Ubuntu 14.04 using either ubuntugis or the debian repo. When opening QGIS I get the following error screen: When I click on "Connection Certificates", the ...
0
votes
0answers
53 views

Avoiding 400km shift NW in *.dgn files are shifted 400km (N/W) in *.dgn files with QGIS and Ubuntu?

I received .dgn files with VN2000 projection. You can find the files here. I can open them with QGIS easily by using the Browser Panel. The dataset includes lines, polygons and point. I am being ...
1
vote
1answer
162 views

Geoserver printing (2.8) fails: InvalidValueException

I have followed this well-known sequence to use the Geoserver printing module: cd /var/lib/tomcat7/webapps sudo wget http://ares.boundlessgeo.com/geoserver/2.6.x/geoserver-2.6.x-latest-war.zip sudo ...
0
votes
1answer
68 views

postgresql out of memory [closed]

I clip 70 raster with polygon in postgresql, the result are: out of memory, Fatal on request size of 10872 I read some solution about changing the postgresql.conf parameter but nothing work for me ...
1
vote
3answers
315 views

ogr2ogr without spatialite support - How to fix it?

I am trying to use ogr2ogr to convert OSM data from pbf to spatialite. I used to do so with the following command: ogr2ogr -f "SQLite" -dsco SPATIALITE=YES png-full-last.db planet_137.084,-15....
1
vote
1answer
90 views

No GDAL/OGR package for Ubuntu 15.04?

Using Ubuntu 15.04, I'm trying to install GDAL/OGR. I did: [] sudo add-apt-repository ppa:ubuntugis/ubuntugis-unstable [] sudo apt-get update However, I found this error message W: Failed to ...
1
vote
1answer
103 views

GDAL install on Ubuntu 12.04 works for python 2.x but not python3

I need to install gdal 1.10 or greater to be compatible with python3 on ubuntu 12.04. The machine also has python2 installed. I followed instructions here Error While installing GDAL in Ubuntu 12.04....
1
vote
1answer
65 views

Load testing WMS capabilities for GeoServer instance?

I would like to load test the WMS capabilities for our GeoServer instance. How should I go about this? Server is running 64 bit ubuntu 14.04, Oracle Java 8, and geoserver 2.7.2 I know I could ...
1
vote
2answers
258 views

QGIS 2.8 Ubuntu 14.04 installation issues. Terminal command attempts to install 2.10 regardless of repository

I have switched to a new computer, and need to re-install QGIS 2.8. I imagine some database changes have happened since I last installed it, because now, even though I direct installation to the http:/...
1
vote
0answers
568 views

Error While installing GDAL in Ubuntu 12.04

I am trying to set CartoDB in Ubuntu 12.04. I am trying to install Python dependencies as a part of my installation. I am installing with below commands export CPLUS_INCLUDE_PATH=/usr/include/gdal ...
1
vote
1answer
542 views

Tile server - problem with tiles loading (pink tiles)

I have built a tile server by following this instruction: https://switch2osm.org/serving-tiles/building-a-tile-server-from-packages/ and i have a problem. When i test tile server using http://...
1
vote
0answers
40 views

Layer failed to load?

I have this piece of codes running via pyqgis and trying to get raster layer from "elevp.csv". However, when executing this scripts it error kept returning "Layer failed to load". Anyone know how to ...
1
vote
0answers
158 views

How to properly config the Qgis Web Server and Web Client on ubuntu 14.04

I'm trying to properly install and config the web server and web client on an ubuntu machine (14.04) For now, I'm just testing it, to present later to my boss. I followed these links: qgis-web-server-...
0
votes
1answer
929 views

gdal2tiles.py gives ERROR 6 about EPSG:900913 on fresh Ubuntu 14.04 install

I have a fresh install of Ubuntu 14.04. I installed gdal with sudo apt-get install gdal-bin python-gdal. After this I have: GDAL 1.10.1 released 2013/08/26. I am trying to tile the weather radar ...
0
votes
1answer
126 views

Building GDAL with libcurl support on Debian Linux

Does anyone know how to build GDAL with libcurl support on Debian Linux (specifically LinuxMint and/or Ubuntu)? After following build instructions here and tip from @EvilGenius below, I'm specifying ...
2
votes
1answer
61 views

Custom data entry form (.ui) crashes qgis

I'm using Linux Mint 17.2, qgis 2.8.1 and have also tried this on 2.10: Made a simple form using qt4 designer The field names match those in the attribute table used the properties page of qgis ...
1
vote
1answer
43 views

unknown parameter: -conf Error in osm2pgrouting

I was just going through the following tutorial HERE. I have extracted all the files succesfully using the below commands: cd ~/Desktop/pgrouting-workshop/ tar -xvzf data.tar. But when i run the ...
1
vote
2answers
284 views

Trying to build OSRM: Could NOT find OSMPBF

I am trying to build OSRM on a Ubuntu system (14.04 LTS, up-to-date, 64 bit), but I am getting a "Could NOT find OSMPBF" error. First I followed the Ubuntu 14.04 instructions on the Building on ...
0
votes
0answers
52 views

Geoserver on linux gives corrupted tiles on windows

I have a Geoserver running on Ubuntu Linux 15.04. Layers that I upload look just fine on any Linux machine, however, when I test my application on a Windows, maps look like this: Do you have any ...
1
vote
0answers
19 views

MrSID on QGIS 2.10 Ubuntu [duplicate]

i have Qgis 2.10.1 Pisa and GDAL 1.11.2, and i cant open MrSID (.sid) images en QGIS, i have lost three days trying to make it work, but i cant make it. My linux is 14.04 trusty tahr. Thanks ! ...
0
votes
0answers
60 views

Installing mapbender3 with wordpress on one server

I am trying to install mapbender on my server (ubuntu) on which I installed before Wordpress (with multisites option enabled). I tried to do it according to this instruction: http://doc.mapbender3....
3
votes
1answer
277 views

QGIS 2.10 with ubuntugis dependecies Grass issues Ubuntu 14.04

I saw in How to correctly install QGIS 2.8.3 with GRASS plugin on Ubuntu 14.04? how to get Qgis 2.10 running from the non ubuntugis repository with grass features but I'm still having problems with ...
2
votes
1answer
315 views

Is it possible to import .ecw images into QGIS 2.10 for UBUNTU?

We want to import .ecw images. We have done it using QGIS 2.8 for Windows in the past, but we can't using QGIS 2.10 for UBUNTU. Thanks.
1
vote
0answers
143 views

What could be making QGIS 2.10 crash when loading a project file?

On QGIS 2.10, running on Ubuntu 15.04 Linux, I have a project file that has a fairly large number of mainly shapefile layers, which gets to 99% on the slider to the right of where it has a message ...
5
votes
2answers
3k views

How to correctly install QGIS 2.8.3 with GRASS plugin on Ubuntu 14.04?

I already tried to install QGIS 2.8.3 using the procedure described on: http://www.qgis.org/en/site/forusers/alldownloads.html#debian-ubunt, but grass-plugin do not compare on plugin list! I tried ...
1
vote
4answers
298 views

Permission Denied when installing openstreetmap server

I am installing a tile server from this link on my Ubuntu Machine 14.04. The problem I am facing is in this line : ./make.py cd ../OSMBright/ carto project.mml > OSMBright.xml Whenever I enter '...
2
votes
1answer
106 views

python crashes with returned gdal band object from a function

I wrote these two functions in a module when I want to read the band in NetCDF or HDF files and return the band outside the function. Each HDF and NetCDF has many subdatasets. Each subdataset in a ...
3
votes
1answer
345 views

How to re-compile ogrinfo against gdal used by QGIS?

I just solved a problem with missing libraries blocking use of ogrinfo and ogr2ogr, only to find that these utilities are garbled in one more way: whenever I run any of these, I get following error (...
3
votes
3answers
2k views

How to repair broken GDAL and PROJ.4 on Ubuntu?

EDIT2: I solved the library problem, but others remain, only vaguely related to that of PROJ.4 library not loaded. I asked a follow-up question for these. My GDAL package and PROJ.4 library are ...
2
votes
2answers
99 views

Install QGIS on ubuntu using the compressed format qgis-2.8.3.tar.bz2

I just cant use apt install becuase slower internet connection and size of QGIS can you show me how to do insall using qgis-2.8.3.tar.bz2 file. I have tried decompressing and use the command ./...
1
vote
1answer
147 views

Installing two versions of QGIS in Ubuntu?

I would like to have two versions of QGIS (2.8.2 and 2.8.10) in Ubuntu 14.04. I have tried to do it by using the SIG sem grilhetas tutorial. However, it didn't install qgis 2.8.2 in my ubuntu 14.04....
1
vote
0answers
30 views

Processing Model .model from Ubuntu to windows and “vice versa” Python Error

I have prepared a processing model in Qgis 2.10 under ubuntu 15.04, I tried to test it on a Windows(7) pc with Qgis 2.10 and I got a Python error message, Then I tried the opposite way, I prepared ...
3
votes
1answer
108 views

Is it possible to have v.in.lidar without compiling GRASS?

I already have installed libLAS like this: sudo apt-get install liblas-bin And Ì have installed GRASS GIS 7 from the ubuntugis-unstable repository. Is it possible v.in.lidar without compiling ...
2
votes
1answer
368 views

Grass 7 no longer works via the Processing Toolbox on Ubuntu

When I try to execute a Grass 7 algorithm via the Processing Toolbox in QGIS 2.10, 2.8.2 or 2.8.1, I get the following error: Missing dependency. This algorithm cannot be run :-( QGIS ...
1
vote
1answer
189 views

Unable to build develop environment for Geonetwork 3

I've been trying to build Geonetwork development environment using the steps from https://github.com/geonetwork/core-geonetwork/tree/develop/software_development Here is the stacktrace, when building ...
1
vote
2answers
268 views

How to compile QGIS from source with Grass?

I recently decided to reinstall QGIS and build against the latest version of GDAL - something I have been putting off for ages because I suspected it would be a nightmare. Lo and behold it has been, ...
2
votes
2answers
234 views

GDAL/QGIS broken Ubuntu 14.04

I think I've managed to bust GDAL after (I think) installing Grass7. I had previously built GDAL (1.10) from source with a bunch of additional drivers. When installing Grass7 GDAL 1.11 was installed. ...
2
votes
1answer
220 views

Why does the QgsFeatureIterator crash in my stand alone script?

I'm trying to write a standalone script in qgis 2.10 in ubuntu I have written a script which crashes when I run from bash but works fine from inside the qgis desktop environment. The script is: #!/...
3
votes
2answers
3k views

Where to download QGIS 2.10?

Is QGIS 2.10 Pisa for Ubuntu/Windows already available?
2
votes
2answers
705 views

Attempt to install QGIS 2.8 on Ubuntu 15.04 installs old version instead

I previously had installed QGIS 2.8 with the GRASS plugin on Ubuntu 14.04. Through a chain of events I ended up having to do a clean install of Ubuntu 15.04, and am attempting to re-install QGIS 2.8. ...
0
votes
1answer
480 views

Import point cloud into PostgreSQL/ pdal pipeline fails

I have a point cloud dataset that I would like to upload to my postgres/postgis database. I followed this tutorial and I could install everything without problems (on ubuntu 14.04. On ubuntu 12.04 ...
1
vote
1answer
152 views

Error while installing osm2pgrouting Ubuntu14.04

I'm trying to install osm2pgrouting. I have installed all the required packages and I also have changed the #include "libpq-fe.h" to #include postgresql/libpq-fe.h" in the src/Export2DB.h. However ...
0
votes
1answer
105 views

Run the GUI of JTS 1.12

I've got an error in JSTS (JavaScript Topology Suite) library based on JTS (Java Topology Suite) v1.12 (r405). But there is no error in the last build of JTS on the same test case. So I want to check ...
0
votes
0answers
145 views

How to add local OSM tile server to Geonode

I have created 2 virtual machines each containing an installation of Geonode and an OSM Tile Server respectively. I would like to add the local OSM Tile Server to Geonode by following the tutorial ...
2
votes
2answers
198 views

ERROR 1: None of ECW_ENCODE_KEY and ECW_ENCODE_COMPANY were provided

I downloaded ERDAS-ECW_JPEG_2000_SDK-5.1.1 and tried to use it with GDAL to create ECW files from georeferenced PNG files, but they are not created, it basically complains about: ERROR 1: None of ...
3
votes
2answers
2k views

How to activate GRASS GIS 7 plugin in QGIS 2.8?

Apparently, my linux ubuntu setup of QGIS doesn't contain grass gis, although when I initially installed it last week I added grass gis to the command line. Anyway, I typed in once again and installed ...