Ubuntu is a computer operating system based on the Debian Linux distribution and distributed as free and open source software, using its own desktop environment.

learn more… | top users | synonyms

0
votes
1answer
139 views

Ubuntu QGIS 2.4.0 SSL connection to remote PostGIS fails b/c can't specify certificates

I can connect with SSL in PGAdmin to my remote server, but it requires specifying the filepaths for certificate files due to my having different certs for different servers. However, when connecting ...
1
vote
1answer
228 views

Spatialite error: obsolete libspatialite

I am learning to use QGIS with the QGIS training manual (from the QGIS website). One of the excercises is to load vector data from a database (ch 3.1.3 in case you have the manual). When I try to do ...
1
vote
2answers
991 views

Geonode installation on Ubuntu fails

attention: This might be more a question for "askubuntu.stackexchange" but it is GIS-related Geonode 2.0 is available for Ubuntu 12.04 but not for Ubuntu 14.04. According to the docs it should be ...
0
votes
2answers
2k views

How do I install PostgreSQL + PostGIS + MapServer + Python-MapScript on Ubuntu 12.04 LTS w/o compiling from source?

This question is similar to the one posted here... How to have PostGIS 2.1 and the Python osgeo library installed together without compiling from source? ...but since I'm new GIS Stack exchange, I ...
1
vote
2answers
2k views

Problems while installing Mapserver on Ubuntu

I followed instructions at http://www.mapserver.org/installation/unix.html but it didn't work well. My system is ubuntu 14.04 and I'm a total rookie when it comes to unix/compiling/working with the ...
3
votes
1answer
335 views

Conflicts while installing postgresql9.3-postgis2.1,QGIS and gdal-bin

I want to use postgresql9.3-postgis2.1 and gdal-bin parallel . I have refer instruction here for installing postgresql-9.3 on ubuntu 12.04. I have install qgis from here While installing gdal-bin it ...
1
vote
0answers
33 views

Sending commands into FGDB

I have a large .gdb of all blocks in the United States, available from Census. I would like to create a point shape file of all census tract centroids in the US. I have QGIS with FileGDB enabled, as ...
2
votes
2answers
227 views

Writing data into Esri *.mdb personal geodatabase using QGIS?

I have an empty *.mdb database that I have to fill with data. The problem is that I cannot install ArcGIS for Desktop on Ubuntu, so I decided to do it using QGIS 2.0.1 with a Grass plugin. However, ...
2
votes
2answers
245 views

OpenGeo postgres installation not working from command line but works from PGadminIII on fresh install

Problem: I just did a default install of opengeo suite (4.1) on Ubuntu 12.04 and followed instructions exactly. The problem is that I can connect just fine to my postgresql through pgadminIII (1.18....
3
votes
3answers
3k views

Qgis server on Ubuntu Server 14.04: Permission denied

I'm trying to install and configure Qgis Server (2.0.1) on a virtual server with ubuntu 14.04, Apache 2.4.7. After trying to install normally, the server gave me 404 error, so I tried to add ...
6
votes
3answers
4k views

PostGIS non functional on Ubuntu 14.04

I am unable to create the PostGIS extension on new databases in Ubuntu 14.04: $ psql pg_testing -c "create extension postgis" ERROR: could not load library "/usr/lib/postgresql/9.3/lib/postgis-2.1....
2
votes
0answers
70 views

Opengeo and Ubuntu memory issue

I was working with LiDAR in Opengeo suite while following the Boundless tutorials (http://workshops.boundlessgeo.com/tutorial-lidar/) In my recent post titled 'LiDAR and Opengeo', I mentioned about ...
2
votes
1answer
1k views

Python support with QGIS 2.4 on Ubuntu 14.04

I recently updated my Ubuntu system to version 14.04. I added the sources and installed QGIS as per the directions on the QGIS website. Everything looks good, except for I do not have all the ...
0
votes
0answers
339 views

I cannot use Gdal Python but Gdal binary, how to fix?

**UPDATE: I can use GDAL with Python now by copy file from Gdal 1.11 compiled folder to Python package folder. But the problem with GDAL binary and GDAL library that they cannot read the HDF5 file. ...
1
vote
2answers
786 views

How to install pgRouting in Ubuntu 14.04?

I want to install pgRouting in Ubuntu 14.04 LTS. I added the respective repository (https://launchpad.net/~georepublic/+archive/pgrouting-unstable?field.series_filter=trusty) but failed to install the ...
0
votes
1answer
912 views

Reverse geocoding Nominatim results

I need to obtain street intersections from reverse geocoded lat/long, where there is no house number information. I have a tile server and Nominatim running in Ubuntu 12.04 virtualbox. I followed ...
0
votes
0answers
44 views

Couldn't load PyQGIS in QGIS 2.2 on Ubuntu 14.04 [duplicate]

This issue appears to be occurring with some frequency to folks in some shape or form. I upgraded from ubuntu 12.04 to 14.04, with loss of python functionality. My QGIS version is 2.2 from the ...
1
vote
0answers
210 views

Problems installing libgdal-ecw package

I have problems to visualize ecw files for qgis 2.3.0 using ubuntu 12.04 LTS. From terminal, following the instructions for qgis 1.8 found at ECW for QGIS 1.8 in Ubuntu 12.04, because launching the ...
2
votes
1answer
167 views

libLAS las2las scrubs ground point data on Ubuntu?

I am trying to use las2las from libLAS on Ubuntu 14.04 entering the following code into the terminal: las2las --input merged.las --output ground.las --keep-class 2 This outputs a LAS file which has ...
2
votes
1answer
276 views

Why is the QGIS 2.2 database tab missing?

I have recently installed QGIS-2.2.0 but the Database tab in the top-menu bar is missing. It looks the main reason is missing libgdal1h library. But when I am installing it, it's removing Postgresql-9....
2
votes
2answers
1k views

Qgis installation fails on Ubuntu 14.04 [closed]

I am having problems installing Qgis on Ubuntu 14.04 (Trusty). I tried several approaches: installing from the Ubuntu standard repos, installing from http://qgis.org/debian and installing from http://...
6
votes
1answer
3k views

Problems installing QGIS 2.2 on Ubuntu 14.04

After major upgrade to 14.04 I tried to purge and reinstall QGIS. Unfortunately I get and error (full listing below) and cannot finish clean installation. Information in the log points errors to ...
1
vote
0answers
807 views

Error adding Geoserver store from PostGIS

I cant get a connection up when creating a PostGIS-store. Geoserver is running fine on IP:80/geoserver. PostGIS is running and working fine with psql commands Created database/table 'mydb' and '...
4
votes
1answer
1k views

“Couldn't load PyQGIS” Error running QGIS on Ubuntu 14.04

I have installed QGis on Ubuntu 14.04 from the QGis stable repository; it went fine with no errors reported. But when I launch QGis I get this huge window with the following message: Couldn't load ...
0
votes
1answer
145 views

Opening TileMill from Ubuntu launcher after building from source

I build TileMill from source following this tutorial. Now I can open it by going to the folder cd ~/tilemill and run node index.js. This all works fine. But I want to open it using the Ubuntu launcher....
1
vote
2answers
971 views

How do I add and view *.ecw raster images in QGIS 2.2.0 on Ubuntu 14.04 LTS

How do I make ECW files work in Quantum GIS on my Ubuntu 14.04?
4
votes
5answers
5k views

Unable to install ECW support on lubuntu 14.04

I try unsuccessfully to install the ECW support (mainly to use ECW file in QGIS 2.2). We attempt to follow and adapt the howto provided by makina-corpus. My first supprise was the repository ...
7
votes
2answers
718 views

Unable to get python-qgis-common on Kubuntu 14.04

just upgraded my Kubuntu from 13.10 to 14.04 LTS and lost all plugins. Found out that "python-qgis-common" is not installed. Tried to install it but was told that it depends on "sip-api-10.1" which ...
0
votes
1answer
162 views

WmsGetFeatureInfo not working in larger scales

I use Openlayers/Geoserver on ubuntu server. Geoserver runs at tomcat6. I have grouplayer of several layers all shown at certain scales. When I click at feature at small scale, getfeatureinfo works. ...
1
vote
0answers
139 views

Ubuntu Touch and QGIS?

I'm planning buying a tablet for running Ubuntu. There are little info on experience with Ubuntu Touch and QGIS and does it work? What I want is to run it on the tablet, drawing polygons etc on screen,...
0
votes
1answer
76 views

How to find qgis2 folder to delete in ubuntu

How can i find the qgis2 in qgis and where it is installed, i had one error on when qgis open this error will occurred "[ERROR] Can not make qgis.db private copy" some links told delete the folder ...
0
votes
2answers
487 views

Accessing GeoServer on my own domain

I am running GeoServer 2.4.3 on Ubuntu Server 12.04 and tomcat7 and I want to access it on mydomain.com. I have searched a lot and found the all the solutions suggest to use a ProxyPass. One of the ...
1
vote
1answer
274 views

GeoServer subdomain, where to place a html file

i would like to host a website, which is addressable as a subdomain of my GeoServer. For example http://mygeoserver.com:8080/geoserver/web/my_website.html. My question is: where do i have to place ...
0
votes
2answers
530 views

Can't install CartoDB on Ubuntu Lucid - mapnik dependency issue

Previously asked this question at askubuntu - but maybe here is the right place. I'm trying to install CartoDB, and have run into the dreaded "you may have requested an impossible situation" message: ...
1
vote
0answers
8 views

Simple solution for escaping the QGIS locked into fullscreen mode on Ubuntu 12.04 [duplicate]

" No crash in this case, but I made the mistake of toggling to fullscreen mode on my netbook running Ubuntu 12.04. It's now impossible to escape this "No Menus" view, and it seems to have disabled ...
7
votes
3answers
5k views

Installing Postgis on Ubuntu 12.04: unmet dependencies libgdal1

After sudo apt-get install postgresql-9.1-postgis I got that massage: The following packages have unmet dependencies: postgresql-9.1-postgis : Depends: libgdal1 (>= 1.9.0) but it is not going to ...
1
vote
0answers
238 views

Load MrSID file in QGIS 2.2 on Ubuntu 13.10

Is there a way to do this? I have tried a number of the write ups on this, and it appears that libgdal-mrsid-src no longer exists. Is there any other workaround? USDA NAIP imagery is sent as MrSID.
3
votes
1answer
388 views

Qgis 2.2 how to fix bad epsg.wkt load

I installed Qgis 2.2 this morning from the ubuntugis repository for ubuntu precise. Qgis works great, except that all the common projections have been deleted. So, I am a Little bit having a heart ...
7
votes
3answers
3k views

How to configure QGIS and SAGA on Ubuntu (12.04 and others)?

During the past weeks, I have tried QGIS to recognize SAGA via the processing toolbox, both being installed from the ubuntugis-unstable repository. I have tried this on several virtual ubuntu ...
3
votes
2answers
304 views

spatialite - azimuth function not available

I am working with last spatialite versions on both Windows (7) and Ubuntu (13.10). I installed these from reference spatialite website. For both, version that I downloaded is 4.1.1 (nevertheless in ...
0
votes
1answer
245 views

No building and Point of interest available while setting up “Rendering Osm Data Ubuntu using MAPSERVER”

I have followed RenderingOsmDataUbuntu 10.10 and set up Google styled web map using mapserver. The osm-google.map seems to be not using table osm_new_buildings. Also no POI (Point of interest) data is ...
1
vote
5answers
1k views

Problem installing PostGIS on Ubuntu Server 13.10

I've installed PostgreSQL 9.1 and postgis on Ubuntu Server 13.10 as follows: sudo add-apt-repository-ppa:ubuntugis/ubuntugis-unstable apt-get update apt-get install postgresql-9.1-postgis then I ...
0
votes
2answers
633 views

How to install PyWPS on Ubuntu?

Since PyWPS is not yet packaged for Ubuntu an installation guide would be handy. This guide should target a vanilla Ubuntu LTS install, detailing the required dependencies.
0
votes
1answer
707 views

Installing Geoserver on Ubuntu 13.04 - “ trying to overwrite '/usr/bin/shp2pgsql-gui' ”

I am trying to upgrade Opengeo Suite from 2.0 to 4.0, specifically for the upgrade of PostGis 2.0 to 2.1, I followed the instructions outlined on this page: http://suite.opengeo.org/opengeo-docs/...
1
vote
1answer
803 views

How to install pgrouting on Postgresql 9.2 located at /opt/PostgreSQL/9.2/ on Ubuntu Server 12.10?

I have installed Postgresql 9.2 on Ubuntu Server 12.10 using one-click installer from the EnterpriseDB. Then using the StackBuilder I installed PostGIS. Now I also want to install the pgrouting ...
0
votes
1answer
167 views

Geoserver integrated GWC not 'seeing' tiled layers

I am having trouble using Geoserver 2.4.1 integrated GWC, Ubuntu 13.04 and tomcat7 My data directory is set by setenv.sh with this string: export CATALINA_OPTS="$CATALINA_OPTS -DGEOSERVER_DATA_DIR=/...
8
votes
2answers
3k views

Install PostGIS and TIGER Data in Ubuntu 12.04

Could someone write a brief albeit dumbed down idiot's guide to installing postgis and loading national Tiger data on ubuntu? I've tried a few guides, namely, http://wiki.bitnami.com/@api/deki/pages/...
4
votes
4answers
589 views

How to install everything “geo” in Ubuntu?

I am new to ubuntu SAUCY and I must confess the transition from windows has not been really easy for me. on windows everything seems pretty much straight forward but I am getting frustrated because It ...
0
votes
2answers
533 views

Building CartoDB from source using updated dependencies on Ubuntu 13.10

I am attempting to build CartoDB from source on an Amazon VM for the first time in my life. For purposes of sanity, I want to use the same instance/database of postgres for both CartoDB and all of my ...
0
votes
2answers
124 views

Python Error in QGIS Ubuntu 13.10 while trying to join .csv tables

Using the mqgis plugging in QGIS I cant join my csv file... This is what QGIS returns me: An error has occured while executing Python code: Traceback (most recent call last): File "/home/elisabet/...