Ubuntu is a computer operating system based on the Debian Linux distribution and distributed as free and open source software, using its own desktop environment.

learn more… | top users | synonyms

10
votes
3answers
10k views

ECW for QGIS 1.8 in Ubuntu 12.04

I have followed various online help guides on how to make ecw for QGIS 1.8 work in Ubuntu 12.04. I had it all working in Ubuntu 10.04 but since migration to 12.04 no such luck. Is there a guide that ...
1
vote
0answers
213 views

Problems installing libgdal-ecw package

I have problems to visualize ecw files for qgis 2.3.0 using ubuntu 12.04 LTS. From terminal, following the instructions for qgis 1.8 found at ECW for QGIS 1.8 in Ubuntu 12.04, because launching the ...
0
votes
0answers
30 views
+100

Qgis globe plugin (2.16) missing on Ubuntu 14.04

I just upgraded from Qgis 2.14 to 2.16 and I can't get the Globe plugin to work. Apparently, under Ubuntu it is necessary to install it separately. But in the Ubuntugis repository, only version 2.14 ...
1
vote
2answers
290 views

How to compile QGIS from source with Grass?

I recently decided to reinstall QGIS and build against the latest version of GDAL - something I have been putting off for ages because I suspected it would be a nightmare. Lo and behold it has been, ...
1
vote
1answer
183 views

Geoserver printing (2.8) fails: InvalidValueException

I have followed this well-known sequence to use the Geoserver printing module: cd /var/lib/tomcat7/webapps sudo wget http://ares.boundlessgeo.com/geoserver/2.6.x/geoserver-2.6.x-latest-war.zip sudo ...
0
votes
1answer
38 views

Where to find a version of libgeos-c1 compatible with libgeos-3.5.0?

This morning a number of Python scripts stopped functioning after a system upgrade. libgdal is no longer available, resulting in the following exception: ImportError: libgdal.so.1: cannot open shared ...
1
vote
1answer
42 views

Restoring PostGIS 2.1. dump in PostGIS 2.2

I tryed to restore my old PostGIS dumps (Postgis 2.1, PostgreSQL 9.1) at my new system (PostGIS 2.2 and PostgreSQL 9.5) I was using pgadmin3 to dump the databases and was now trying to restore it ...
0
votes
2answers
305 views

PostGIS broken after Ubuntu 16.04 upgrade

I upgraded Ubuntu from 15.01 to 16.04 and PostGIS is broken. Below are the errors: psql (9.5.2) Type "help" for help. osm=# select version(); version ------...
0
votes
0answers
9 views

Error while instaling CartoDB editor

I am trying to install CartoDB on ubuntu 12.04 x64 by following this instruction: http://cartodb.readthedocs.io/en/latest/install.html. Everything went fine until line: RAILS_ENV=development bundle ...
1
vote
1answer
74 views

QGIS update failed

Until yesterday my whole qgis and python-qgis worked fine with version 2.14 under Ubuntu 14.04. After a simple sudo apt-get update and sudo apt-get upgrade qgis failed to update... Several attempts to ...
2
votes
3answers
987 views

QGIS install on Ubuntu 14.04 fails

Following the QGIS installation guide I have tried both UbuntuGIS and QGIS stable, but both fail with the error message: The following packages have unmet dependencies: python-qgis : Depends: python-...
1
vote
1answer
611 views

Tile server - problem with tiles loading (pink tiles)

I have built a tile server by following this instruction: https://switch2osm.org/serving-tiles/building-a-tile-server-from-packages/ and i have a problem. When i test tile server using http://...
1
vote
1answer
32 views

shp2pgsql-gui not work after Ubuntu update

I'm using Ubuntu 14.04 with postgres-9.5 and postgis 2.2.2. Previously I performed shp2pgsql-gui to access the interface, but now, the terminal shows me this message: the program shp2pgsql-gui not ...
0
votes
2answers
651 views

How to install PyWPS on Ubuntu?

Since PyWPS is not yet packaged for Ubuntu an installation guide would be handy. This guide should target a vanilla Ubuntu LTS install, detailing the required dependencies.
0
votes
0answers
16 views

SAGA-GIS (2.3.1) fatal error during compilation (Ubuntu 16.04) hdf5.h not found in /usr/include/vigra/ subdir

OS : Ubuntu 16.04 Compilation using : ./configure && make I encountered a fatal error while compiling SAGA-GIS 2.3.1 : Making all in imagery_vigra make[5]: Entering directory '/home/...
4
votes
1answer
224 views

Linux Tool to visualize CityGML file

I am looking for a linux program that allows me to visualize CityGML models (3D). I have tried a whole bunch so far (most of them via wine but also native ones) but I couldn't get a single one of them ...
1
vote
0answers
29 views

QGIS options menu causes freeze on Ubuntu 16.04, solutions?

First time asking, I've checked the internet and no luck. I am unable to edit the program options in QGIS 2.14.3 running on Ubuntu 16.04 (settings -> options). I've uninstalled all QGIS packages (...
0
votes
0answers
25 views

Installing LASzip in Ubuntu?

I have tried without any success to install LASzip¹ ² (paper by Isenburg about LASzip) on Ubuntu 16.04. The basic way gave me nothing relevant: ./configure && make & checkinstall which ...
3
votes
2answers
872 views

wine + LAStools in QGIS 2.8.1, Ubuntu 14.04

I can't get wine + LAStools to work in QGIS 2.8.1 (ubuntu 14.04). I only get the 22 open source functions that comes with QGIS. Outside qgis wine + LAStools works fine. My guess is that I am not ...
3
votes
1answer
347 views

Conflicts while installing postgresql9.3-postgis2.1,QGIS and gdal-bin

I want to use postgresql9.3-postgis2.1 and gdal-bin parallel . I have refer instruction here for installing postgresql-9.3 on ubuntu 12.04. I have install qgis from here While installing gdal-bin it ...
0
votes
0answers
13 views

Qgis Server error while loading wms layer in qgis

I have created qgis server by following link http://hub.qgis.org/projects/quantum-gis/wiki/QGIS_Server_Tutorial and http://docs.qgis.org/testing/en/docs/user_manual/working_with_ogc/...
1
vote
2answers
1k views
1
vote
0answers
31 views

How to change which python GDAL is “connected” to?

I would like to use GDAL with Python 2.7 on Ubuntu 14.04. I have installed gdal-bin and python-gdal from UbuntuGIS following their instructions. However, importing GDAL (from osgeo import gdal) only ...
1
vote
0answers
51 views

QGIS with GRASS on ubuntu 16.04

Following the advice on How to correctly install QGIS 2.8.3 with GRASS plugin on Ubuntu 14.04?... I've installed qgis, qgis-plugin-grass, python-qgis, grass-core=6.4.3-3, grass=6.4.3-3, grass-doc=6.4....
0
votes
1answer
200 views

Why doesn't OpenLayers Plugin 1.3.6 show in Internet menu on Ubuntu 14?

I installed QGIS 2.8.1 on Ubuntu 14.04 LTS 64bit (from repository http://qgis.org/debian trusty) I installed OpenLayers Plugin 1.3.6 It doesn't show in main menu (Internet) like on Mac Do I miss ...
1
vote
1answer
520 views

CartoDB with external access in Ubuntu 12.04.5

I'm following the guide at https://github.com/CartoDB/cartodb to install CartoDB on my Ubuntu server. Last time I've installed it, it was successful, but while trying to modify it to be able to ...
1
vote
1answer
40 views

What is the correct (QGIS) syntax for a masked PostQIS spatial query?

What is the correct syntax if I want to query a masked region from PostGIS from inside QGIS ? The data is from "planet_osm_poly" (imported via osm2pgsql) and I'd like to use a polygone from a ...
1
vote
3answers
375 views

ogr2ogr without spatialite support - How to fix it?

I am trying to use ogr2ogr to convert OSM data from pbf to spatialite. I used to do so with the following command: ogr2ogr -f "SQLite" -dsco SPATIALITE=YES png-full-last.db planet_137.084,-15....
2
votes
0answers
33 views

QGIS segmentation fault related to numpy on Ubuntu

I'm running QGIS 2.14 on Ubuntu 14.04 and everything's been working just fine until I upgraded a few Python packages via pip this afternoon. Since doing that, QGIS crashes with a segmentation fault ...
0
votes
1answer
35 views

Installing QGIS-Server on Ubuntu 14 (64-Bit AWS EC2 Instance), /cgi-bin/ doesn't work

I've been trying to install qgis-server (2.14) on Ubuntu 14 (64-bit) using instructions from the the qgis-server installation instructions and tips from this question. All the packages install, I can ...
0
votes
0answers
35 views

renderd: encountered during parsing of layer 'landuse_gen0'

I am trying to set up open street map on a Ubuntu machine on Amazon. I have imported the whole world into postgresql and it took many days. I am following the tutorial at https://switch2osm.org/...
2
votes
1answer
74 views

Cannot update GDAL on Ubuntu

I am trying to use GDAL_Rasterize and found a link via Google that suggested that there were bugs in older versions. I am running Ubuntu 14.04 LTS and 'gdalinfo --version' gives me 'GDAL 1.11.2, ...
1
vote
0answers
231 views

QGIS Crashes with OpenLayers plugin

I've just updated to QGIS Brighton on Ubuntu 14.04, and I've noticed that when I open Openlayers plugin, in order to load google layers, the whole program suddenly crashes. The only log I see, when ...
1
vote
0answers
52 views

ogr2ogr not running on Ubuntu 15.10

I'm trying to convert an osm.pbf file to a spatialite db but I can't get ogr2ogr to run. I have qgis 2.14.2 and ubuntu 15.10. I've reinstalled gdal-bin and I'm getting the following message from the ...
1
vote
2answers
152 views

The connection was reset deploying geoserver.war in ubuntu

I have installed Tomcat 7 in Ubuntu and when I try to deploy geoserver.war I receive the error "The connection was reset" in Firefox and "402 Access Denied" in Chromium. How do I deploy geoserver.war?...
1
vote
0answers
12 views

NVIZ not installed/working?

I am running GRASS GIS 7.0.4 on Ubuntu 16.04. After completing a tutorial on extruding vector data, I tried running the nviz command to see the result in a 3D-view. This is in norwegian, but it ...
0
votes
3answers
1k views

How to install QGIS with OpenGeo Suite on Ubuntu

I was wondering how should one install QGIS after installing OpenGeo Suite on Ubuntu Linux? I installed OpenGeo 4.1 on Ubuntu 12.04 following the instructions on the official website http://suite....
9
votes
3answers
3k views

Install QGIS 2.14 Essen on Ubuntu 16.04 Xenial

I'm having trouble installing QGIS on Xenial. `debian` release When I try using the debian release (i.e. without ubuntugis dependencies) I get the following errors (please note there is no xenial ...
2
votes
1answer
179 views

QGIS Segmentation fault (core dumped)

QGIS 2.14 works fine until a couple of day (ubuntu 15.10 wily). QGIS crash at startup with only this error : Segmentation fault (core dumped) sudo qgis don't give any error but qgis don't start. ...
3
votes
3answers
2k views

How to repair broken GDAL and PROJ.4 on Ubuntu?

EDIT2: I solved the library problem, but others remain, only vaguely related to that of PROJ.4 library not loaded. I asked a follow-up question for these. My GDAL package and PROJ.4 library are ...
1
vote
2answers
824 views

How to install pgRouting in Ubuntu 14.04?

I want to install pgRouting in Ubuntu 14.04 LTS. I added the respective repository (https://launchpad.net/~georepublic/+archive/pgrouting-unstable?field.series_filter=trusty) but failed to install the ...
15
votes
7answers
18k views

How can I enable Shapefile GUI Loader in pgadmin3?

I have installed PostgreSQL 9.1 with PostGIS 1.5.3 on Ubuntu 11.10. I also installed pgadmin3 1.14.0-beta1, following this instructions. If I remember correctly, when I installed PostGIS on Windows ...
1
vote
3answers
672 views

GDAL build from source throwing OpenSSL errors on Ubuntu

I'm trying to get GDAL installed/up to date on my Ubuntu machine, and I can't seem to get it to work properly. I've been following this process: https://milkator.wordpress.com/2014/05/06/set-up-gdal-...
0
votes
1answer
44 views

Local Nominatim install accessing with API

I have installed a local Nominatim install on Ubuntu using the instructions located at http://wiki.openstreetmap.org/wiki/Nominatim/Installation and I am using Apache. The installation appears to ...
1
vote
1answer
52 views

How to get QGIS to use dedicated graphics card over integrated

does anyone know how i'd be able to get QGIS in either windows or Ubuntu to use the dedicated graphics card over the integrated graphics? I am attempting to speed up the processing of a supervised ...
1
vote
0answers
25 views

Why does QGIS spontaneously corrupt shapefile data? [duplicate]

I'm using QGIS 2.14 (Mac), but I have had the same problem with 2.8 (Ubuntu). When I am editing a shapefile, QGIS seems to spontaneously corrupt the data in unpredictable and catastrophic ways that ...
3
votes
2answers
3k views

How to activate GRASS GIS 7 plugin in QGIS 2.8?

Apparently, my linux ubuntu setup of QGIS doesn't contain grass gis, although when I initially installed it last week I added grass gis to the command line. Anyway, I typed in once again and installed ...
0
votes
0answers
69 views

Geoserver not starting

I have downloaded Geoserver 2.8.3 on a fresh Ubuntu installation which I access via SSH. I installed Java 8 and setted up JAVA_HOME and GEOSERVER_HOME to the right locations. When i run ./startup.sh ...
2
votes
2answers
1k views

How to install proj4rb on Ubuntu 14.04?

I am trying to install proj4rb on Ubuntu 14.04. Three methods are provided in the README file, but they all fail. 1. Using gem $ gem install proj4rb Building native extensions. This could take a ...
2
votes
1answer
1k views

Fetch Python Plugins missing

I'm running QGis master v1.9.0 on xubuntu and the 'fetch python plugins' option is absent. This guy had this problem with vanilla 1.7.5 but fixed it by upgrading to 1.9.0 master. Nishant had this ...