Ubuntu is a computer operating system based on the Debian Linux distribution and distributed as free and open source software, using its own desktop environment.

learn more… | top users | synonyms

7
votes
2answers
6k views

ECW for QGIS 1.8 in Ubuntu 12.04

I have followed various online help guides on how to make ecw for QGIS 1.8 work in Ubuntu 12.04. I had it all working in Ubuntu 10.04 but since migration to 12.04 no such luck. Is there a guide that ...
3
votes
4answers
2k views

Cannot fix QGIS after upgrade to Ubuntu 13.04 Raring

I have following problem. After upgrade to 13.04 I had problem with PyQGIS mentioned here. I followed almost all advices described there, finally removed QGIS (had 1.8 Lisboa) and added the Ubuntugis ...
13
votes
4answers
679 views

Migrating to Linux from Windows

I am looking at switching over a computer from Windows to Ubuntu. I have been a Windows user all my life and been using GIS for over a decade. I am curious about the migration to Ubuntu. Mostly, ...
15
votes
9answers
22k views

How to install QGIS on Ubuntu 12.04?

Has anyone had any luck with getting QGIS working on Ubuntu 12.04? I have tried the stable and unstable versions and with not luck. I also get the following: "Some packages could not be installed. ...
3
votes
2answers
5k views

How to install PostgreSQL 9.2 with PostGIS 2.0 on Ubuntu 11.10 (or higher)?

I have read this question: Install PostGIS v2 for PostgreSQL v9.2, but it didn't resolve my problem. I added the PostgreSQL backports PPA and installed the postgresql-9.2 package, but there is no ...
1
vote
1answer
3k views

'Couldn't load PyQGIS' after upgrade to Raring Ringtail?

I upgraded my Ubuntu to Raring Ringtail. After that, when starting QGIS I receive a message: Couldn't load PyQGIS. Python support will be disabled. Traceback (most recent call last): File "", ...
5
votes
1answer
2k views

Install PostGIS on Ubuntu 12.04

I am trying to install PostGIS on Ubuntu 12.04 and I think everything is installed correctly except for postgresql. I followed this post. I get the following error and nothing I do seems to satisfy ...
1
vote
5answers
629 views

Unable to install ECW support on lubuntu 14.04

I try unsuccessfully to install the ECW support (mainly to use ECW file in QGIS 2.2). We attempt to follow and adapt the howto provided by makina-corpus. My first supprise was the repository ...
13
votes
6answers
11k views

How can I enable Shapefile GUI Loader in pgadmin3?

I have installed PostgreSQL 9.1 with PostGIS 1.5.3 on Ubuntu 11.10. I also installed pgadmin3 1.14.0-beta1, following this instructions. If I remember correctly, when I installed PostGIS on Windows ...
4
votes
5answers
5k views

Why can't I add most plugins under Ubuntu 12.04?

I loaded QGIS into 12.04 with much trouble but it works. Although I do not seem to be able to load most plugins. I go to fetch plugins and most are not loaded so I try to load some and they will not ...
1
vote
1answer
130 views

QGIS and Ubuntu 'browse' dialogue causing crashing

Below is an image of 'the suspect dialogue' in Ubuntu that when you encounter it in QGIS you are most definitely going to crash the application. http://ow.ly/i/ZGNc/original You find this ...
7
votes
2answers
2k views

Cannot add plugins to QGIS on Ubuntu 11.10 Oneric

I have installed Qgis on ubuntu. it works fine but I am not getting option to add new plugins only option to manage plugins is available. Please help
4
votes
2answers
2k views

Installing qgis 2.0 and saga 2.1 on ubuntu 13.04

I have been trying to get this working for a few weeks now. I am trying to install QGIS Dufor (2.0.1) and Saga GIS from the Unstable branch of the UbuntuGIS PPA. When I attempt to do this I get the ...
3
votes
1answer
927 views

Problems installing QGIS 2.2 on Ubuntu 14.04

After major upgrade to 14.04 I tried to purge and reinstall QGIS. Unfortunately I get and error (full listing below) and cannot finish clean installation. Information in the log points errors to ...
0
votes
1answer
584 views

What can I do with this unzipped GDB file in QGIS?

I have a zip file that I got from the City department of information technology. Unzipped, it is a directory called DOITT_ZIP_CODE_01_29JUL2009.gdb containing a bunch of .gdbtable and .gdbtablex ...
11
votes
5answers
6k views

Python GDAL package missing header file when installing via pip

I asked this question on Stack Overflow before I realised this site existed. As this site it more appropriate, I'll ask it here too. I'm trying to install gdal from pip pip install gdal inside a ...
7
votes
2answers
4k views

Spatially enabled Postgres database

I am trying to create a spatially enabled PostGIS database. I am following the PostGIS documentation, http://postgis.net/docs/manual-1.5/ch02.html#id2648455. In the short version, i executed, ...
8
votes
2answers
585 views

Building FGDB support for GDAL 1.10 on Ubuntu

Because data.gc.ca is now distributing some of its data in FGDB format (example: Plant Hardiness Zones), I would like to be able to use it with gdal/QGIS. The compile/install is not going as planned, ...
8
votes
2answers
872 views

How to create svg symbols that have modifiable fill color, stroke color and stroke width?

I want to create some svg symbols for Qgis using Inkscape, those symbols must have attributes as described in the question. For the last two days, I have been experimenting as instructed by Sourcepole ...
4
votes
2answers
2k views

Can POSTGIS 2.0 be install with POSTGRES 9.2 on Ubuntu 12.04 OS at the moment?

This question is more about environment set up. At the current moment, March 4th 2013, can POSTGIS2.0 be install with POSTGRES 9.2? I check their website out and to my understanding it is not ...
3
votes
1answer
1k views

GeoServer Web Admin Interface: 404 error

I'm working through the OpenGeo workshop and I'm stuck with setting up a GeoServer. When I try to access the Web Admin Interface localhost:8080/geoserver/, Tomcat reports a "HTTP 404 Status" error ...
2
votes
2answers
603 views

Install PostGIS and TIGER Data in Ubuntu 12.04

Could someone write a brief albeit dumbed down idiot's guide to installing postgis and loading national Tiger data on ubuntu? I've tried a few guides, namely, ...
2
votes
1answer
911 views

QGIS Server Capabilities Response doesn't contain any Layers (Fedora 15 64-bit)

I'm having similar issues running QGIS Mapserver under a fresh install of Fedora 15 (64-bit). The XML response from GetCapabilities will not show the individual layers inside the QGIS project, just ...
1
vote
5answers
2k views

Unable to install the PostGIS extension to PostgreSQL on Ubuntu 12.04 LTS

I just installed Linux Ubuntu 12.04 LTS (on a virtual machine). I then successfully installed the PostgreSQL 8.4 database management system. I am now trying to install PostGIS, which is an extension ...
0
votes
1answer
908 views

Can not make qgis.db private copy

I've just installed Qgis 2.0.1 and the above error message appears. Does anyone know how to resolve this problem? I think I need to change the permissions of the relevant folder, but I'm not ...
5
votes
5answers
4k views

ArcGIS Server 10 on Ubuntu or CentOS?

I know Solaris is on the way out with 10.1 I also know that v10 is only supported on 32bit flavours of RedHat & SUSE. What I do want to know, has anyone had any luck installing it on either ...
2
votes
0answers
99 views

qgis-2.2.0 database tab missing

I have recently installed QGIS-2.2.0 but the Database tab in the top-menu bar is missing. It looks the main reason is missing libgdal1h library. But when I am installing it, it's removing ...
2
votes
2answers
3k views

Installing postgis on postgresql 9.1 not working

I'm trying to install Postgis 2.0 on a perfectly functionig postgresql 9.1.10 database. I installed the package via: richard@srv1:/$ sudo apt-get install postgresql-9.1-postgis postgis Reading ...
2
votes
1answer
306 views

Sextante in Qgis 1.9 alpha on Ubuntu can't find saga gis 2.1

I am using Qgis 1.9 on Ubuntu 13.04, Sextante is a core part of qgis now. I am trying to access the SAGA 2.1 libraries through qgis and I keep getting a popup window that says SAGA is not installed. I ...
2
votes
1answer
526 views

Fetch Python Plugins missing

I'm running QGis master v1.9.0 on xubuntu and the 'fetch python plugins' option is absent. This guy had this problem with vanilla 1.7.5 but fixed it by upgrading to 1.9.0 master. Nishant had this ...
2
votes
1answer
2k views

How do I get and install the latest version of QGIS in Ubuntu?

I'd like to get the latest 64-bit dev build of QGIS on my Ubuntu setup. How exactly do I go about it? I assume it's some kind of arcane terminal command...
2
votes
4answers
1k views

QGIS locked into fullscreen mode on Ubuntu 12.04

No crash in this case, but I made the mistake of toggling to fullscreen mode on my netbook running Ubuntu 12.04. It's now impossible to escape this "No Menus" view, and it seems to have disabled the ...
1
vote
2answers
100 views

Qgis server on Ubuntu Server 14.04: Permission denied

I'm trying to install and configure Qgis Server (2.0.1) on a virtual server with ubuntu 14.04, Apache 2.4.7. After trying to install normally, the server gave me 404 error, so I tried to add ...
1
vote
1answer
351 views

How do I add and view *.ecw raster images in QGIS 2.2.0 on Ubuntu 14.04 LTS

How do I make ECW files work in Quantum GIS on my Ubuntu 14.04?
1
vote
1answer
531 views

Having trouble connecting QGIS with postgres database with postgis extension

I am working on Ubuntu Precise with postgresql version 9.3 and postgis 2.0. After initially starting my postgres database and eventually getting permission errors that would prevent postgres from ...
1
vote
1answer
419 views

unable to install qgis 1.9 on Lubuntu 13.04 [closed]

I tried to install qgis 1.9 in my laptop. I use Lubuntu 13.04 (64bit). I used the repository deb http://qgis.org/debian-nightly raring main deb-src http://qgis.org/debian-nightly raring main ...
1
vote
2answers
1k views

Problem loading vector layer (pyQGIS)

I've installed the qgis on ubuntu 12.04 following the instructions on http://hub.qgis.org/projects/quantum-gis/wiki/Download. I am trying to test the Python API and try to do the follwoing from ...
0
votes
0answers
123 views

Why are some values missing from the imported CSV?

Bit of a strange one: i'm importing a CSV where the rows are the WKT data for regularly progressing rectangles from a grid, then the rectangle name, then values (ranging between 2 & 254). When I ...
0
votes
2answers
545 views

Install Opengeo 3.0.1 in ubuntu 12.04

I tried to install OpenGeo community edition 3.0.1 in Ubuntu 12.04. In the installation instruction it is mentioned that this version is supported only "10.04 and ...