0
votes
1answer
89 views

Geomedia WebMap WFS to vector marker layer in Openlayers

Looking for minimal example/advice on getting a WFS service to show up as a vector layer with markers/icons in Openlayers map. I have created the WFS service in Geomedia WebMap 6.01.11.19 and the ...
2
votes
1answer
112 views

How to stop features to redraw unwillingly in OpenLayers

I have a problem where when editing features from a wfs vector layer. After some changes are made to the geometry, the feature redraws itself and the changes are lost. Usually the problem occurs more ...
2
votes
0answers
476 views

how to search a vector/wfs layer

I'm using Geoserver/PostGIS/openLayers I've succesfully set a vector layer. And now I'm trying to create a search functionality. But something goes wrong. First I set up the layer and add some basic ...
2
votes
1answer
701 views

LoadingPanel - Waiting for Vector & WFS loading

I have vector layer with WFS protocol. and because I have a huge amount of data, there is a while before features loaded on the map. So i need to tell user to wait a moment until they load by ...
1
vote
1answer
134 views

BBOX strategy to load all features?

Since I have no way, other than using BBOX strategy with my vector layer + wfs protocol Is it required to use BBOX strategy with WFS protocol in OpenLayers? I'm wondering if there is a way to force ...
1
vote
2answers
713 views

Is it required to use BBOX strategy with WFS protocol in OpenLayers?

is it a must to use BBOX strategy with WFS protocol in Vector layers ? I cannot display this layer without BBOX strategy: vLayer = new OpenLayers.Layer.Vector("Test", { styleMap: new ...
0
votes
4answers
3k views

OpenLayers (allOverlays): Vector layer not rendered without raster layer beneath it

This is another newbie question. I'm trying to create a map using OpenLayers that comprises only of vector layers from a WFS server. However, I'm thwarted because my vector layer won't render unless ...
0
votes
1answer
1k views

openlayers- WFS- Cross-domain problem

I got the typical cross-domain problem when access to WFS layer by using openlayers, XMLHttpRequest cannot load http://XXXX/geoserver/ows?service=WFS. Origin http://XXXX is not allowed by ...
6
votes
1answer
4k views

Openlayers wfs vector layer

I'm trying to add a vector layer with a wfs layer and it's not working.Can anyone point a solution? Openlayers code: var wfs = new OpenLayers.Layer.Vector( "Stavros Features", ...
3
votes
1answer
3k views

Reproject a vector layer (EPSG:27700) using WFS onto a googlemaps background (EPSG:900913)

I have the following HTML-javascript code and i have problems reprojecting the vector layer (WFS) from EPSG:27700 (British National Grid) to EPSG:900913 (googlemaps). I managed to project the WMS ...
4
votes
4answers
2k views

Openlayers WFS Vector Layer Rules dont get applied

i have a script which applies rules to wfs.vectors. the script works fine in firefox and all the rules get applied, but somehow when i open the same file with the internet explorer 7 / 8 , only the ...