A Web Map Service (WMS) is a standard protocol for serving georeferenced map images over the Internet

learn more… | top users | synonyms

0
votes
0answers
176 views

Displaying ESRI REST Services in OpenLayers 3

I'm looking for an example that demonstrates how ESRI WMS can be displayed with OpenLayers 3. In OpenLayers 2, we had a OpenLayers.Layer.ArcGIS93Rest class (see example and docs). layer = new ...
1
vote
1answer
111 views

OL3 27700 WMS inspire

I am just getting into OL3 from a GIS background - I don't have much of a programming background. I am trying to use WMS layers from inspire in an OL3 app ...
0
votes
1answer
56 views

The WMS Access URLs and Data Format for viz.globe.gov

As I'm reading there are two popular formats for GIS data: KML and WMS. This tutorial says the access URL for the GLOBE WMS GetCapabilities is at ...
1
vote
0answers
34 views

How to color a WMS layer using database value

I have a transparent WMS layer of polygons. It is a map of a city and i want to color the map according to crime rate. Rate values are obtained from database. I dont know how to select a single ...
1
vote
0answers
35 views

Adjust Geoserver home page just to WMS service

I want adjust my first Geoserver home page(Before logging in) just to WMS service! Can anybody help me please?? Thanks.
0
votes
1answer
238 views

Trying to use gdal_translate on WMS

I am trying to export a raster image from a WMS using gdal_translate and have not had any success. I have read http://www.gdal.org/frmt_wms.html but still no success. In my XML file, what should the ...
2
votes
0answers
68 views

Help with Python/GDAL documentation

The instructions from the url http://gdal.org/gdal_tutorial.html give the following example: dataset = gdal.Open( filename, GA_ReadOnly) with the following description: It's interpretation is ...
0
votes
2answers
119 views

WMS layer is distorted

My WMS layer(EPSG:3847) looks fine in GeoServer However, it is distorted in browser: I found someone hade the same problem(Openlayers and Geoserver: OSM/Google Maps and WMS Overlay)but I still ...
3
votes
1answer
48 views

Creating WMS, which can be previewed via ArcGIS JavaScript Viewer, based on buffer model tool?

I am really new to arcgis, so i think you will find this to be an easy question. Arcgis docs are abundant, but however, after too much browsing, i cannot find a concrete answer. these are the ...
0
votes
0answers
7 views

Using CQL to query Multiple WMS layers? [duplicate]

I have two WMS layers, one with points which lie on a state map. I want to use cql to display a particular state and points on it ..when I separate the queries with a semicolon (ex ...
1
vote
0answers
52 views

Basic WMS question

I am kind of new to WMS (I live a sheltered life) so I apologize if this is an obvious question. I requested some data (I assumed it'd be in vector format). I received a WMS link, which I opened and ...
3
votes
0answers
291 views

Add WMS Layer into map using Arcobjects

I am going to add a wms layer to my existing map.I use this code: public load_wms(ESRI.ArcGIS.Controls.AxMapControl mapcontrol) { // Create an WMSMapLayer Instance - this will be ...
0
votes
0answers
38 views

Black polygon covering aerial imagery in QGIS?

I am using FSA 2013 aerial imagery, which I access via WMS in QGIS. In some locations the imagery is covered by a black polygon. The polygon only displays at certain scales. Then, if I zoom out until ...
1
vote
0answers
40 views

Adding a WMS to XMap 8

I'm having trouble adding a WMS to XMap 8, and I'm curious if it can be done at all. I've been using Global Mapper for geologic research for quite a while, which has the ability to download data ...
1
vote
1answer
53 views

Geoserver error 401 using WMS

I've this problem when I try to use an URL of a map WMS for example Prueba de conexión fallida [Test connection failed]: Server returned HTTP response code: 401 for URL: ...
0
votes
1answer
374 views

GDAL WMS Question

I'm new to GDAL and am currently trying to hit a WMS using gdal. I need a way to save the image to my desktop. I currently have an xml file with the WMS description syntax that gdal wants -> ...
1
vote
1answer
26 views

OSM basemap WMS for 2 different years

Is it possible to get OSM basemap WMS for two different years ( 2000 and 2010 )
0
votes
1answer
135 views

Legend in GeoExt.tree.LayerContainer

Using the code below in this jsfiddle example: tree = new Ext.tree.TreePanel({ renderTo: "tree", root: new GeoExt.tree.LayerContainer({ text: 'Map Layers', ...
0
votes
1answer
250 views

WMS blank map returned

I am facing this problem 3th day and I really don't know where is the problem, so please help me. Here is my REQUEST: ...
2
votes
1answer
147 views

GeoServer rendering performance significantly affected by vector icon size

I'm having the craziest GeoServer experience right now and I was hoping to get some input on what might be causing this behaviour. I'm using Apache Bench to benchmark rendering performance for a ...
0
votes
1answer
120 views

Geonetwork harvesting metadata

I'm using Geonetwork version 2.10.3 to harvest OGC WMS service metadata but it gives me this message when i hit save button Unable to add a new entry Error : error Message : String index out of ...
4
votes
2answers
341 views

“Shapefile to WMS” with FME

I'm using FME Desktop and Server 2014. At the moment my workspace looks like the following. It reads a .csv file and transforms this to a ESRi Shapefile. This is working. I can use the shapefile with ...
0
votes
0answers
42 views

Geowebcache wms cql_filter parameter not working

I am using the geowebcache stadalone to increase the performance, but I can not use cql_filter. GeoserverWmsUrl: http://localhost:8080/geoserver/ISUPGIS/wms GeowebcacheWmsUrl: ...
0
votes
1answer
135 views

GeometryCollection styling in Geoserver

I am trying to style an GeometryCollection geometry data type from PotGIS table in Geoserver. I have not found any examples on the Internet how to do it nor is it supported in Geoserver or not. When I ...
1
vote
0answers
50 views

geoserver wms layer doesn't see

I've created a new layer, and styled with an .sld file (categorized by value). It works, if I check with Geoserver OpenLayer Preview, but when I citate for this in a .html It doesn't appear. Is the ...
1
vote
1answer
98 views

Displaying WMS Attribute Data in Lizmap

I have successfully built a Web server using ubuntu 14.04, Qgis 2.6, with the plug-in lizmap as a local server. I have several polygons being displayed and some WMS raster's from NOAA's WMS. I know ...
5
votes
2answers
3k views

WMS getFeature control doesn't take 'viewparams' into account

I use Geoserver to get my WMS data. Everything works great for showing data in openlayers. Geoserver has the ability to create sql views and use parameters to return certain geometry. These ...
0
votes
0answers
57 views

In OpenLayers, WMS layers get dislocated on window resize

In a low zoom level, like 3 (my max extent), my WMS layers are dislocated relatively to the rest of the map. I think this happens because on the left side of my page, I have a menu that I can ...
0
votes
1answer
108 views

Openlayers GetFeatureInfo not working all zoom levels

I am sending GetFeatureInfo request to wms service. My parameter is like this. When I click to map, map click event is firing and I am sending this request to server. var params = { ...
0
votes
0answers
30 views

The location of tiles according to their coordinates

I am using a standalone GWC 1.2.4 to cache Ortho photos and after the caching job was completed, I noticed that there are some blank tiles here and there and on different zoom-levels. Is it possible ...
7
votes
3answers
6k views

How to make geoserver return JSON for WMS GetFeatureInfo?

I wish to get the results of a WMS GetFeatureInfo request as a JSON instead of the table that comes up by default. Out of the box, the only options for the response from a WMS GetFeatureInfo are the ...
0
votes
1answer
210 views

Problem with connecting remote WMS connection to GeoServer

In my geoserver admin panel I try to connect new stores - remote WMS connection: ...
2
votes
1answer
38 views

wms with time dimension

I set up a layer with "time" dimension in Geoserver, but I'm having quite a hard time figuring out how to use it... It is a vector layer with some polygons in it. This is my layer configuration for ...
1
vote
2answers
201 views

Non-standard WMS parameters not sent in GetMap requests via QGIS?

I am coding a python plugin to QGIS that connects to the UK National Biodiversity Network (NBN) Web Mapping Service (WMS). In general, I don't have any problems doing this with the QgsRasterLayer API ...
0
votes
0answers
53 views

Getting error when consuming WMS (created from ArcGIS Server) from QGIS 2.4

I have created WMS and WFS using ArcGIS Server. I further deploy the authentication towards both services using the users & rolese set by ArcGIS server built in store. For example, user with ...
1
vote
1answer
103 views

How to locate the WMS on a ESRI basemap?

I need to locate the WMS (not WMTS) for the following ESRI Ocean Basemap for use in a WMS only application: http://goto.arcgisonline.com/maps/Ocean_Basemap Is this possible?
0
votes
0answers
76 views

GeoServer 2.6 + PostgreSQL 9.3.5, GeoServer becoming unresponsive

We're displaying point vector data on a web client using an OpenLayers (2.12) WMS layer... rendered via a GeoServer SQL View reading from data in PostgreSQL. The particular layer has a viewParam on ...
1
vote
1answer
162 views

How to cache Geowebcache tiles from applications

I have enabled disk quota to cache tiles that produced by WMS. Geoserver admin panel Tile Caching->Tile Layers list of cached layers. I can preview here on a demo page. ...
1
vote
0answers
23 views

Raster overview hierarchy in WMS [duplicate]

I have rasters with low resolution which covers the whole area, and in certain spots i have some rasters with higher resolution which covers small parts of the same are covered by the lower raster ...
2
votes
0answers
47 views

QGIS returns “invalid layer” when adding a WMS layer

I want to add a WMS layer in my map. I select the server and obtain the list of layers that are published there. I select one of them (the problem is the same with all layers), but QGIS does not load ...
0
votes
1answer
126 views

Openlayers stylemap label not working wfs

I have created a style map like following: var scadaPointStyle = new OpenLayers.StyleMap({ "default": new OpenLayers.Style("null", { "rules": [ new ...
1
vote
0answers
71 views

GeoServer Integrated GeoWebCache and Layer Group Mode

I've been told that in previous versions of GeoServer it was possible to cache the individual layers which make up a layer group and that requests for the layer group would then return the relevant ...
3
votes
2answers
90 views

Map widget in .NET application

I would like to have map widget in .NET application. I need basic functions (zoom, move map) and possibility to display WMS. Thats all. Is there any library that you recommend for that? I am ...
0
votes
1answer
33 views

Combining two TileWMS with different axisOrientation using OpenLayers3?

I have two TileWMS, one that has map data, with terrain, roads and stuff. And one that only is images that should be placed upon the map. Both uses the same projection, ESPG:3006. The one hosting ...
9
votes
4answers
4k views

How to avoid Pink tiles when DB view/Table is empty?

I have views that are spatial in a sense that they select some spatial column from other table. This table is published using geoserver. This table is live and sometime has no data at all. When the ...
2
votes
1answer
2k views

GeoServer + ArcMap

I need to setup GeoServer and access GeoTIFF images in the ArcMap. I have started with installing Geoserver and created a layer with GeoTIFF. Now, what are the next steps to publish the map(using WMS) ...
1
vote
1answer
128 views

Using WMS external SLD with OpenLayers application

I want to use external SLD file in my OpenLayers application. So I created WMS layer like this: var ly= new OpenLayers.Layer.WMS("mylyer", serverurl, { layers: ...
0
votes
1answer
473 views

Show map using esri leaflet, with 4326 spatial reference

I have this MapServer http://geoservices.big.go.id/arcgis/rest/services/RBI/Rupabumi/MapServer It turns out it uses 4326 spatial reference. I want to present it using leaflet, my code so far: ...
0
votes
0answers
94 views

Geoserver wms tile cache and saving

I am new at geoserver. I have created a wms service on geoserver that serves water pipes. Geoserver using postgresql database as data store. Client applications (like Openlayers) are consuming wms ...
1
vote
1answer
58 views

Geoserver strange inverse polygon rendering

I found strange behaviour of rendering one particular polygon on Geoserver. Red polygon in the link. If you compare SHP data from ZIP file in some desktop software like QGIS and rendering from ...