A Web Map Service (WMS) is a standard protocol for serving georeferenced map images over the Internet

learn more… | top users | synonyms

0
votes
1answer
96 views

Geoportal resource URL to Geoserver does not show Preview link in search result

I have a Geoportal catalog entry with a resource URL like: http://data.ilri.org:8080/geoserver/nurc/Arc_Sample/wms?request=getcapabilities However the preview link is not shown in the search ...
1
vote
1answer
263 views

Openlayers vector layer with WFS protocol not refreshed properly after Insert,Update and Delete operations

In my web map application, I have added the wfs vector layer for feature editing. Everything is working fine except the refresh function of wfs vector layer. Refresh function with force ture option ...
0
votes
0answers
100 views

OpenLayers - feaures from WMSGetFeatureInfo are not shown on layer (but they exists)

I have a project with google as base layer and geoserver serving WMS layers (structures - multipolygons) that are in EPSG:2039 The layers are showing fine on google base layer (I guess OL re-project ...
2
votes
1answer
741 views

Problem with WFS-T save strategy in Openlayers

In my web map application, I have added the editable wfs vector layer for feature editing. But in save strategy method, Insert and Update Geometry is working fine.But Update Attributes is not saved in ...
1
vote
1answer
143 views

Openlayers map projection not working while saving the features into PostGis

In my web map application, I have added the wfs vector layer for feature editing. There is no issue When I save the feature in postgis after editing. But when I refresh the wfs layer, its showing the ...
0
votes
1answer
327 views

geoserver wms layer is very slow

I am using open-layers to display a map and I have vectors layer with some features that I'm loading with ajax from MySql, and I'm using geoserver to load all the background from shp files(like ...
0
votes
0answers
41 views

WMS Problem in ArcGIS Server 10.1

I have created a WMS service for big tile map. ( I'm using ArcGIS Server 10.1) Because I don't have enough space in C drive, I create another folder in another drive and copied tile image to that ...
0
votes
1answer
411 views

OpenLayers: Properly use a WMS layer to display a TMS layer from a different server

I have two servers: the first server is 177 and that has a html file with the TMS layer. We will call this tms_layer.html and it has your init function with this in there: var tmsoverlay = new ...
2
votes
2answers
529 views

MySQL with geoserver

I am storing all my features in mysql db and I am getting them with ajax and adding to the openlayers map. Now I have to many features and it's taking a lot of time to get all of them and adding them, ...
0
votes
1answer
1k views

Loading WMS Tiles on Android using Google maps v2

I'm using Google Maps v2 to display tiles from a wms. I referred this site. Problem in loading tiles, tiles are loading multiple times i dont konw y? Can any1 help me. Here is my code package ...
0
votes
0answers
431 views

How to add WMS Layer from openweathermap?

I've tried to add some WMS Layers to my webmap using ESRIs Java Script API. I'm very interested in using weather WMS layers and I've already found some usefull. If there is anything better free ...
0
votes
1answer
1k views

How to put more than one overlay label in Openlayers layerswitcher?

I have two set of layers like 'Public' and 'Private'.Each set has 3 layers. My requirement is, Layer switcher has to show the first set of layers with check-box under the label name 'Public' and ...
0
votes
0answers
64 views

OpenStreetMap shp layer is shifting

I am dealing with this issue more than 2 month and i am hoping that some one have a lead for me. I am using Openlayers to show some vectors layers like buildings, points, gardens and more layers that ...
0
votes
1answer
204 views

QGIS Server loads only one .qgs project file

I installed QGIS Server in WinXP via OSGeo4W and runs great. But the problem is, it loads only one .qgs project file. I restarted Apache but it is same. I use QGIS 1.9 default WMS client. I noticed ...
2
votes
1answer
65 views

DC-GIS WMS server. Metadata shows polygon layer, why am I getting a raster

This page gives the description of the layers available from the DC_GIS mapserver. When I look up the metadata for various layers, say record lots, the description says Geometry Type: ...
2
votes
1answer
263 views

Getting Layer in WMS and Editing in WFS-T on OpenLayers [closed]

I have huge datasets on PostGIS. For example building table includes more than 100k features in POLYGON geometry. When i want to get all data in QGIS(2.1) or other GIS softwares by using direct DB ...
1
vote
1answer
191 views

Error using SLD with MapServer based WMS (GeoBC)

I'm trying to customize rendering of map tiles from a government WMS server. When I use the GetStyles WMS query to retrieve the SLD for a layer, then feed that SLD directly back in a GetMap query, ...
1
vote
0answers
148 views

ArcMap 10.1 and MapProxy: what is the differense between WMS, WMTS and “Layer.OSM” [closed]

On Ubuntu I have PostgreSQL, postgis, renderd, mapnik, mapproxy. 1) I have OSM. It is rendered by Mapnik. 2) Then I have MapProxy. So I have this OSM by WMS protocol. 3) I also can have this OSM ...
2
votes
0answers
159 views

How can I create a WFS from netCDF file(s)?

Currently I'm working on a project that uses OpenLayers and Geoserver to view data from a postGIS server (both on a map through a WMS, and as data through a WFS). Now, I'd like to be able to compare ...
0
votes
0answers
104 views

Problem in Adding line feature in Openlayers vector layer

I have added the WMS line feature in vector layer. But I am facing some display problem in it as shown below screenshot.Is there anyother way to do this? But there is no issue in point features. ...
2
votes
1answer
325 views

How can I use wms service layers to edit in openlayers?

I'm new to openlayers. I'd like to edit a feature layer of wms service in openlayers. I created a wms service using ArcGIS server 10. I couldn't use the wms layers to edit using the openlayers ...
1
vote
2answers
235 views

GeoServer map layers/tiles Loaded in the screen or Not

I'm using OpenLayers - 2.11,GeoServer 2.13, ExtJS 3.4, and Java for developing GIS based web applications. Please guide me to check if all my GeoServer map layers/tiles Loaded in the screen or not. ...
2
votes
1answer
3k views

Combine Leaflet with Geoserver WMS map

I'm not very skilled within the GIS world, however, I would like to know if it's possible to use this map: ...
0
votes
1answer
813 views

OpenLayers doesn't proxy WMS requests to Geoserver

I had an issue with WMS requests from OpenLayers to Geoserver via Proxy.php. My OL version is 2.12 and my Geoserver is 2.4.0. I set the variable OpenLayers.ProxyHost as shown in OL documentation, but ...
1
vote
1answer
207 views

Mapserver - Error setting up simple WMS/Mapcache service

I've got a Ubuntu 12.04 computer with Mapserver and all other software on it. I have tried to set up a simple WMS / Mapcache service but have not succeeded. I can browse to the automatically generated ...
0
votes
1answer
79 views

WMS GetCapabilities and variable substitution with MapServer

I have created a layer with a variable substitution to request wether or not a bird species has been observed in a town. It works ok. But if I make a WMS GetCapabilities I only see one layer as ...
-1
votes
1answer
438 views

How to set mouse wheel zooms in ArcMap 10.1? [closed]

We use OSM map in ArcMap 10.1 It is wms service (Our scheme: mapnik -> mapproxy -> ArcMap). Then we set 3857 projection in ArcMap. But sometimes [in some zooms] this map is blank. How to set mouse ...
0
votes
0answers
32 views

How to decide the optimum number of instances of map services for GPS project?

My original question is here: [1]What is the relationship between Map Service Instances and SDE connections? The project is based on Windows ArcGIS Mobile and has similar application to basic ArcGIS ...
1
vote
1answer
88 views

OpenLayers World coverage

I gave a demo this afternoon and it couldn't have gone any worse :( I checked everything was working before I started (apart from the external internet connection).... My dependency on an external ...
2
votes
2answers
377 views

How to import DWG file from CorelDraw to MapInfo project?

I have to make polygons of some protected areas in MapInfo. I have the WMS with the protected areas loaded into mapinfo but making polygons from the WMS will take me years. So I took the following ...
1
vote
2answers
119 views

Mapserver - label at beginning of line string (WMS)

I am creating a WMS service made up of linestrings pulled from a POSTGIS database I want to label the start of each line with a sequence number. At present I can label the centre of each with:- ...
0
votes
0answers
24 views

Is it possible to get all features from mapserver within BBox by clicking external button not on map using WMS GetFetureInfo. [duplicate]

Is it possible to get all features from mapserver within BBox by clicking external button not on map using WMS GetFetureInfo.
1
vote
1answer
303 views

Problem with GDAL_WMS QGIS connecting to an ArcGIS Server?

I've been working, trying to get QGIS (v2.0 32bit) to connect to an ArcGIS Server service using the GDAL_WMS xml file. This is the service I'm trying to connect to: ...
0
votes
1answer
245 views

XMLHttpRequest cannot load error When we have GeoServer and WebServer on same domain

I have Geoserver and webserver on same domain (Windows XP with IIS). But when i tried to get WMS feature info, i got this error in chrome. If Geoserver and webserver on same orgin, no need of proxy i ...
1
vote
1answer
63 views

Legends for WMS layer on Geoserver

Is there any way to get a representation of a WMS legend in a form that isn't an image? eg XML Using an image for the website in our system will mean the text is not sharp, it doesn't resize with the ...
0
votes
1answer
69 views

Geoserver, WMS-T and time ranges

I got a case where WMS-T is desired, preferably using GeoServer. The input data contains two date fields with start and end date, which describes a timespan. However, in Geoserver it seems that one ...
-1
votes
2answers
2k views

How to configure Proxy.cgi file for Geoserver On Tomcat?

I have a web map application in my local machine(windows xp and dont have IIS) and I have postgis data in Geoserver on Tomcat (Ubuntu). To get the WMSgetfeatureInfo, I have configured the proxy.cgi ...
2
votes
1answer
547 views

While developing stage, Is Proxy.cgi required to get Openlayers WMSGetFeatureInfo?

I have published the data in Geoserver (Tomcat and OS Ubuntu) and I am developing a map application in my local machine (OS windows xp) using asp.net. In my application, I can get WMS feature ...
0
votes
1answer
264 views

GCS_WGS_1984 and 900913. What is the difference?

I use WMS Service with mymapproxy/mapproxy.yaml : services: demo: kml: tms: wmts: wms: srs: ['EPSG:4326', 'EPSG:900913'] md: title: MapProxy OSM WMS Proxy abstract: This ...
0
votes
2answers
423 views

Use GetFeatureInfo with OpenLayers and a Bounding Polygon

I want to be able to draw a bounding polygon and have my MapServer WMS layer return every feature within that bounding box. I have it working for a single point, but I would like for the query to ...
1
vote
1answer
308 views

Leaflet Legend fixed image? not SLD?

I have a style pulled from my GeoServer and have created a basic legend, with a fixed PNG. However I was wondering if it is possible to have this legend be pulled from the layers SLD? so that if the ...
0
votes
0answers
100 views

Google and Croatia WMS do not line up with shapefiles (500 meter to East)

I am working on a project in Croatia. I can use the WMS files from geoportal.dgu.hr/wms. These line up perfectly with the google maps. As project CRS I use HTRS96/TM which has become standard in ...
3
votes
2answers
191 views

Can QGIS display individual WMS tiles as it fetches them?

I have a QGIS project accessing a base WMS layer with imagery. How can I tell QGIS to display the individual tiles as it fetches them so that I won't wait for the whole image to load until I see ...
2
votes
0answers
198 views

WMSGetFeatureInfo : No feature found on click

My map displays well my WMS layers. When i try to get the feature info, the debugger tells me no feature is found features: Array[0] , length :0 I don't know if it is because of a projection issue: ...
0
votes
1answer
325 views

OpenLayers CQL filter gets info about NOT VISIBLE features

I have a WMS layer and a control WMSGetFeatureInfo. If I apply a CQL Filter to the layer and I redraw it, the WMSGetFeatureInfo control continue querying also NOT VISIBLE features. Why in your ...
2
votes
0answers
47 views

Can't connect to WMS service? An Amazon-EC2 problem?

I'm running GeoServer 2.3.5 on a Windows instance in AWS for the first time. The data is on the server in PostGIS. The map layers have been published and I can see them locally without any problems. ...
1
vote
0answers
296 views

WMS Query does not return all records (Geoserver)

This is a tricky one - so bear with me... i'm a Geoserver newbie... Basically, i have two very similar queries that return species records for a given species in a given geograpic area. One query ...
0
votes
0answers
187 views

OpenLayers animated zooming only for baselayer (not whole map / all layers)

With 2.13 release OpenLayers now has animated zooming. Is it possible to get the animated zooming only for the baselayer not for the whole map (i.e. all layers)? The problem is a have a topology ...
2
votes
2answers
258 views

Stitching MapProxy tiles to receive one georeferenced image?

In my struggle to get a decent aerial image for playing around with as a layer in Biosphere3D (and for other purposes as well), I managed to install Mapproxy and then cached the area in my desired ...
2
votes
1answer
45 views

Placing TIF image on the top of WMS layer

How to place TIF file on the top of WMS layer in QGIS? When I import TIF file, it has different coordinate system, and it is placed far from WMS layer, but I want to put this TIF layer on the top of ...