Tag Info

Hot answers tagged

10

you can find very detailed information about Jetty and Apache httpd (from http://wiki.eclipse.org/). i think you should decide what you want from a web server more precisely according to the expectations. Apache httpd is a HTTP server written in C, that is often used to front other web services. Jetty is a full functional and optimized HTTP server ...


7

If you're using Ubuntu, you'll first have to configure Apache $sudo ln -s /etc/apache2/mods-available/proxy.conf /etc/apache2/mods-enabled/proxy.conf $sudo ln -s /etc/apache2/mods-available/proxy.load /etc/apache2/mods-enabled/proxy.load $sudo ln -s /etc/apache2/mods-available/proxy_http.load /etc/apache2/mods-enabled/proxy_http.load Then append the ...


7

As tile caches are pregenerated map images, you will really be testing the underlying map / wms / image server. Unless you are testing against a pregenarated cache, in which case you are testing the web server itself (Apache / IIS etc.). Stress testing for websites is often done using JMeter. There was a recent series of posts on using JMeter at ...


7

GeoServer is a Java web application packaged as a WAR file. It needs to be deployed in a Java servlet container of which Apache Tomcat is an implementation. You could also use another servlet engine like Jetty. So in order to use GeoServer, you will be obliged to use a Java servlet container. If you want to avoid the use of a servlet engine, you could also ...


6

I wrote up my notes on how to do this on a Linux box (but the process is similar on a windows machine). Specifically you need to have Apache redirect the requests to the tomcat at localhost:8080 - you need to edit a couple of files.


5

I have faced the same problem: "Internal Server Error with Ubuntu 12.04". Everything looked OK to me (I even run successfully a perl fcgi script to test FCGI in my apache server). I continually got an Internal Server Error when I run a get Capabilities request. The apache log file said "Premature end of script headers: qgis_mapserv.fcgi". The problem was ...


5

to avoid the cross origin policy that prevents evil sites from stealing your credit card details by accident. See http://trac.osgeo.org/openlayers/wiki/FrequentlyAskedQuestions#WhydoIneedaProxyHost for more details.


5

I have found for windows users using the Enterprise Postgres Installers with StackBuilder the easiest way to get up and running from a clean install (no previous versions of database etc.) The PostgreSQL installers include the database server, pgAdmin and StackBuilder. Notes: **Internet Connection is required during the install as downloads items based on ...


4

A quick solution to serve up shapefiles on a basemap in a webapp is through a free arcgis.com account. They allow you upload .shp files, symbolize, and lay them on a base map. The share tool allows provides a html script that can be copied. I served up some symbolized counties to my blogger page in a webmap. Note that ESRI is trying to monetize arcgis.com ...


4

This depends on what you want & need. Do you only need "dead" bitmaps, or do you need "alive" objects in your client? There are numerous solutions out there, depending on your needs. You need a client in your browser, OpenLayers is perhaps the most prefered open source solution. As for the service backends, e.g WMS and WFS, Geoserver and Mapserver ...


3

Due to Javascript security rules, you are not allowed to make an XMLHttpRequest to another server. Even two servers running on the same machine, but different ports have this limitation. What you need to do, is to have a cgi proxy on your tomcat webserver, and use the OpenLayers.ProxyHost to point to it. The OpenLayers site has a FAQ Answer for this issue ...


3

Well for the connection between mapserver and postgis you should check mapserver documentation at http://mapserver.org/input/vector/postgis.html That's for the data connection, then you have to style your data (MapServer docs are great) and then decide which client to use. You are asking for tiled pngs so I assume you are looking for a web mapping client. ...


2

You need to edit server.xml file. Open up the Server.xml file and search for Connector. The top Connector will have the port that you're trying to communicate through, in my case 8080. In between port="8080" maxHttpHeaderSize="8192" type address="0.0.0.0" (Line will look like port="8080" address="0.0.0.0" maxHttpHeaderSize="8192"). Cheers!


2

The front end would be OpenLayers. The database would ideally be PostGIS but you could manage with MySQL I guess. You might want Geoserver in there too. For background data use OpenStreetMap. http://www.osgeo.org for all things open source geo.


2

In this case it is because your sample proxy script from Open Layers is written in Python. Changing the header line just changes the language that your cgi file tells the server that it's in. You either need to modify your apache server to run Python (see here for one method) or alternately download a Perl proxy and modify it for your purposes, for example ...


2

You do not need to configure proxypass and proxypassreverse. You will need a proxy.cgi file written in python, and python installed on your server. you can get the proxy file with the openlayers distribution in the example folder. you will have to configure the path to python interpreter in the 1st line, and add your host to list of allowed hosts.


2

The mapserver documentation has an example on using mapserver in tile mode here. For the styling this is a basic example of a class and style for LINE layer type: CLASS NAME 'BLUELINES' STYLE WIDTH 7.0 COLOR 0 0 255 END END which renders lines in blue with a width of 7 SIZEUNITS. Sizeunits are defined at layer level and default to ...


2

a few hours later I found my problem: I discovered apache logs at /var/log/apache2/error.log. An error read "(2)No such file or directory: apache2: could not open error log file /etc/apache2/${APACHE_LOG_DIR}/qgis-web-client-error.log. Unable to open logs". So I searched my qgis-web-client.conf for this line and found it and added the directory to the ...


2

I assume that your Apache is on port 80 and your Geoserver is on the same machine on port 8080. I would suggest that you set up a reverse proxy on your Apache server. On my server I have set up Apache to resolve http://example.com/geoserver to http://example.com:8080/ That way I can just use the wms link as http://example.com/geoserver/wms & I don't ...


2

For Ubuntu sudo apt_get install postgresql postgis postgresql-9.1-postgis sudo -i -u postgres createdb postgis psql -d postgis -f /usr/share/postgresql/9.1/contrib/postgis-1.5/postgis.sql psql -d postgis -f /usr/share/postgresql/9.1/contrib/postgis-1.5/spatial_ref_sys.sql psql -d postgis -f /usr/share/postgresql/9.1/contrib/postgis_comments.sql


2

for a quick solution, you can check out shapefile-js. A binary shapefile loader and canvas-based renderer, for javascript. Many caveats. test it: http://www.prodevelop.es/files/fm/public/downloads/jldominguez/shp.html more info: Rendering local shapefiles with HTML5 http://www.prodevelop.es/en/blog/11/12/11/rendering-local-shapefiles-html5 and my ...


2

The link in the question had the answer (whoa... Zen). The location of arcgisscripting is defined in the Windows environment variable PYTHONPATH. By printing sys.path from a CGI script I could tell this was missing from the variables Apache was using. Easy fix: add this to httpd.conf: SetEnv PYTHONPATH "c:/path/to/pythonpath" VoilĂ , no more ImportError.


1

The easiest way (at least in Windows): You can use, use EnterpriseDB installer (windows & linux), once you had installed PostgreSQL, use "StackBuilder" utility to install PostGIS optional library (PostGIS recommends this method in his web site) Then you need to install pgAdminIII to connect to PostgreSQL.


1

Okay so I've found the configuration error. It seems that the xampp apache doesn't allow to get any stuff from the server so changing this line in your httpd.conf will solve the problem. # # Controls who can get stuff from this server. # Require all granted to # # Controls who can get stuff from this server. # Order allow,deny Allow from all


1

This has nothing to do with the servlet-api-2.5.jar (note that the message that refers to this file is an INFO message not an error message). If you want to stop that message appearing just delete the file. The problem starts with this message: 5 mai 2013 14:10:35 org.geoserver.platform.GeoServerExtensions checkContext GRAVE: Extension lookup occured, ...


1

solved the problem using proxy.php. I got the file from the last Mapbuilder app, and its just copy the proxy.php file in my /var/www/ directory. In openlayers edit/add the line OpenLayers.ProxyHost = "/proxy.php?url=" http://lists.osgeo.org/pipermail/openlayers-users/2011-March/019840.html response to comment: To setup the proxy see Geoserver ...


1

In addition to said by iant, I have managed to make my layers publicly available by going to 'Global Settings' in GeoServer's administration interface and setting the 'Proxy Base URL'.


1

Installing the stack is not that difficult. I'm a noob and have done it. In Windows it's trivial. Install postgresql with "stackbuilder" PostgreSQL Windows stack installer. It will ask about installing a PostGIS instance or allow you to do so. Install PGAdminIII, you can connect QGIS to it as well, load data, and you're off to the races. The problem is the ...


1

Ahhh - Sorry I may not have added all the necessary information in my original question. But here are the details of what worked for me. I was using a httpProxy in QGIS. In the section "Exclude URLs (starting with)" I added the server name I was trying to access and that solved the access issue. @dakcarto, I appreciate the speedy assistance you were able ...


1

Sometimes I'm having such problems to setup proxy.cgi to another computers. if finding out why really make you tired, i want to advice you to use proxy.php. you can get it from here. it works similar to proxy.cgi i hope it helps you...



Only top voted, non community-wiki answers of a minimum length are eligible