New answers tagged

1

Try using Null instead of VbNull: iif(InStr(UCase([REQUEST_TYPE]), "SEW") > 0, Null , "Inspection") Although this also seems to enter an empty value rather than a true NULL, which is odd. I'll keep looking.


0

This example work perfectly. from PyQt4.QtCore import * lyr = iface.activeLayer() lyr.startEditing() provider = lyr.dataProvider() provider.addAttributes([QgsField("newAttribute", QVariant.Double)]) lyr.updateFields() lyr.commitChanges()


1

Apologies for being vague, but this is a similar workflow i've used in ArcGIS and I'm sure it can translate to QGIS: Create a uniqueid for your Lakes Select by location Calculate code for Lakes Join uniqueid, code in new shapefile with Lakes uniqueid layer Export new Lakes Layer, delete uniqueid column Or create a python script/tool that will: Iterate ...


0

What you could do 'select by location', selecting only those lakes that fall within a county. Then update 'code' with the county code. I'm sure python could make this a lot faster.


0

Once you have the polygon centroids you could get the coordinates of the centroid and then sort them (e.g. by west to east coordinate) to get the correct order.


4

From the menubar, go to: Settings > Options > Digitizing > Feature creation and disable the Reuse last entered attribute values setting: (I'm sure this was asked before but can't find the post.)


0

I solved this problem as follows: I added new another field attributes, for example, orig_coord = concat($x,' ',$y) and in color rule i added this if("orig_coord" = concat($x,' ',$y),color_rgb(0,0,0),color_rgb(0,255,50)) So I see the color of some of the objects changed their position in the process of moving. Again sorry for my english.


0

If you are just using the "Move Feature" option in QGIS, there is no way to have it automatically update have it update an attribute. If you're moving it using some kind of geoprocessing or plugin, then it depends on which tool you're using to do that.


0

It is because your field names are invalid as (at least) shapefile column names and QGis seems to expect shapefile conforming field names. These must start with a letter not a digit.


1

Within the same folder as your csv file, you can save a csvt file which will then provide the field type for each field within the CSV. To do this list the field types you want each field to adhere to in a string within a text editor (notepad works for this) with each field separated by a comma. Make sure the order within the text file is the same as the ...



Top 50 recent answers are included