New answers tagged

0

The accepted method did not work for me because my basemap layer wouldn't show up in the Input Features dropdown. I solved this by doing the following: At the View menu, choose Data Frame Options. At the Data Frame Tab look for "Clip Options" Choose Clip to shape Then click the Specify Shape button Then select the boundary layer as input Apply and the ...


0

As a previous answer stated, I would make sure that both data sets are in the same projection. Another setting to look at would be under the "Environment settings" >> Raster Analysis. You can set your mask here to your clipping layer. You could also look at Processing Extent but that requires another raster as input. A final solution I would try would be ...


1

Try to dissolve the polygons and create only one polygon and use that as a clip polygon. But make sure the projection for both the raster and polygon shapefile is same. Different projections will not give you the desired result. Because if the projections of input polygon and raster are different, the clip based on feature extent will not be activated. If ...


0

You could also use ST_Difference() to get the region in geometry A that does not intersect with geometry B. http://postgis.net/docs/ST_Difference.html SELECT ST_Difference(a.the_geom, b.the_geom) AS the_geom FROM table1 a, table2 b


0

you can also go to the http://<>:6080/arcgis/manager go to the service > Parameters > Properties > Message Level: and set to Info and see the messages


0

Bit of a different situation over here but I was trying to do symmetrical difference operations on two layers that had geographic CRS's (EPSG:4326). Once I changed them to geometric layers with local stateplane CRS's the operation worked well.


1

I think if you want to iterate over your layer using the Clip function, you need to select each polygon first before applying the algorithm. Try running the following: layer_adm_level = QgsVectorLayer(base_path + adm_level + ".shp",'adm_level','ogr') if not layer_adm_level.isValid(): print "Layer failed to load!" for adm_level_feature in ...


6

Try "Select by Location" and set the trees as the Target layer. Set the buffer as the Source layer. Then, for the spatial selection method, use Are within the source layer feature or Are completely within the source layer feature. That should select all the points within the buffer. Now, you have three options: 1) In edit mode, open the 'Trees' ...


1

I think the following parameters requires a minimum value of 1: JPEGCOMPRESSION ZLEVEL PREDICTOR The others can be set to 0 so you could try running the following which works for me: processing.runalg('gdalogr:cliprasterbymasklayer', inputlayer, maskshape, "", False, False, False, 0, 0, 1, 1, 1, False, 0, False, "", "outputraster")



Top 50 recent answers are included