New answers tagged

1

You can use a maxExtent for your map. In combination with a 3rd-party background-layer this can prevent the problem you described. var extent = new OpenLayers.Bounds(-2003750.34, -2003750.34, 2003750.34, 2003750.34); map = new OpenLayers.Map("map", { maxExtent: extent });


0

The solution can be found here: WMS server with CORS enabled? I had the same problem and have been wrestling with it for 15 months. Set up your GeoExt print provider using the POST option instead of the GET option; // The printProvider that connects us to the print service var printProvider = new GeoExt.data.PrintProvider({ method: "POST", // Use ...


0

I found that the issue was that my "GET" requests exceeded the maximum string length. I had to switch to using a "POST" request which then threw an error due to violating the cross origin rule. The solution to geoserver/mapfish printing using the POST option can be found here; WMS server with CORS enabled? Simply paste this code at the beginning of your ...



Top 50 recent answers are included