Hot answers tagged

4

## Iterate through each of the buildings That should be a single comment sign (#), not a double one, otherwise, it tries to parse it as if it was a parameter, and it fails BTW, you do not need to add the script from file. Just save it to the scripts folder, and it will be automatically added to the toolbox Hope this helps!


2

The ST_ClusterWithin and ST_ClusterIntersecting functions in PostGIS first collect all input geometries into a Postgres array before doing their processing. Since the size of this array is proving to be a limitation, you can process this dataset only if you can reduce the total size of this array. Some options for doing this: Use a GROUP BY clause to ...


2

There's been somewhat of a development in QGIS since I asked this question back in 04/2014 so will post an answer to close off this question. The following code does what I had wanted (practically similar to the "Hex grid from layer bounds" script but this wasn't available at the time): ##Create Grid=name ##layer=vector ##cellsize=number 1000 ##grid=output ...


2

You can use the IGpValueTableObject to be Using value tables: A value table is a flexible object that can be used as input for a multivalue parameter. Examples of multivalue parameter values focus on the text value of the parameter that can become difficult to use when there are numerous values with complex paths. The value table is used to ...


2

There seems to be some serious issues with your data excluding the CRS factor. As you have mentioned, the Clip tool works but Intersect does not. As a workaround: Follow the answer provided by @wiltomap to reproject the shapefiles to the same CRS. Use the Clip tool with the buffer layer as your Input vector tayer and the town layer as your Clip layer ...


2

This is a CRS issue. The CRS of layer named 300m_buffer_wgs84 is EPSG:7405, OSGB 1936 / British National Grid. What I suggest you to do is: Save this layer as another layer (change name) and specify CRS with EPSG:4326 (WGS84) before validating. Launch QGIS and disable On-the-fly reprojection (Settings > Options > CRS > Don't enable 'on the fly' ...


1

The 300m_buffer_wgs84 file is not WGS84, but EPSG 7405



Only top voted, non community-wiki answers of a minimum length are eligible