Tag Info

New answers tagged

0

I made a version of WorldFileTool (which I'll call 0.3.8 because the project seems dead) that supports CLI input and can be included as part of a GDAL script: 0.3.8 WorldFileTool jar package download link (personal build) Modified source code tarball (based on subversion repository) Command line argument: java -jar WorldFileTool.jar ...


1

The correct syntax is: ogr2ogr -f GeoJSON geojson.json Areas.kml You can also use togeojson (Online Maps moving forward, from KML to GeoJSON) togeojson Areas.kml > geojson.json


4

I think you may need to process this file yourself - either manually, or by writing a script to automate the extraction. If you rename the file GMRT.kmz to GMRT.zip you can open it in WinZip or similar, and see its contents. This includes the file doc.kml, which contains a number of Links - examining the first link shows a URL: <Link> ...


1

That loads two raster layers in Google Earth. I don't think QGIS (through GDAL) supports reading that KMZ (not a KML) because of it. ogrinfo below can't recognize the geometry, even with the libkml (google) driver. ogrinfo -ro -so GMRT.kmz -al ERROR 1: ERROR Parseing kml Style: No id ERROR 1: ERROR Parseing kml Style: No id INFO: Open of `GMRT.kmz' ...


1

There is some new functionality for kmls in QGIS which I haven't tried. But along your existing skill/workflow, you should try exporting separate kmls and then bring them together in a folder in GE. Firstly select subsets of your data in QGIS based on Soil Type etc. Then Save Selected As Style each of the kmls in GE, then bring them together in a new ...


2

Typical - after spending hours on this, I realised the answer a few minutes after posting the question to Stack Exchange. At least others can learn from my stupidity. I needed to add a 3rd control point, in order to allow the affine transformation to apply the correct adjustment:


1

You have your input and output datasets in the wrong order. The ogr2ogr syntax is: ogr2ogr [options] dst_datasource_name src_datasource_name [layers] Use the following instead: ogr2ogr -f "KML" geo-kml geo-mif


0

Installing Expat won't be enough - you need to rebuild OGR with expat support. From http://www.gdal.org/ogr/drv_kml.html: KML reading is only available if GDAL/OGR is built with the Expat XML Parser, otherwise only KML writing will be supported.


0

You can convert from multipolygon to polygon with processing algorithm "Convert geometry type". In QGIS menu = Processing->Toolbox. In Toolbox = QGIS geoalgorithms->Vector geometry tools->Convert geometry type


0

You will get the same error if you have not selected the feature in the GUI and then select the layer but hit use only selected features. Also you can try using "vector"->"geometry tools"-> "Multiparts to single parts" This might be installed by fTools, both my installations mac and windows included this tools. The last merge I did I used the dissolve ...


0

WGS84 EPSG:4326 does not have metres as units, but degrees. KML files are always in degrees, so you have to set CRS to that, then reproject the layer to someting else with Save As .... Maybe you have used Set CRS for Layer, which is wrong in most cases. The extents you provide are a bit strange. For the kml, yMin and yMAx are very small, even if the point ...



Top 50 recent answers are included