Tag Info

New answers tagged

1

The problem you ran into has nothing to do with carto, it's an issue with your shell command, when you run sudo carto project.mml > OSMBright.xml carto runs as root, but the file write happens as your normal permission level, to do what your looking for you can sudo sh -c "carto project.mml > OSMBright.xml"


1

I resolved the error by following these steps: Step 1- Create a new file OSMBright.xml in the same folder. Step 2- Type 'ls -l' and see the read and write permission of OSMBright.xml file. Step 3- sudo Chmod 777 OSMBright.xml and it will change the read/write permission of the file. Step 4 - Now do sudo carto project.mml > OSMBright.xml and output ...


0

Have a look ath these instructions from a mapbox article: osm-bright-ubuntu-quickstart There is a section with hints for setting right permissions for database access. Maybe the issue is hidden there?


2

try to add this text-dy: -10; you can look at file admin.mss in openstreetmap-carto project dir and find code #nature-reserve-text[zoom >= 13][way_pixels > 192000] { text-name: "[name]"; text-face-name: @book-fonts; text-fill: green; text-halo-radius: 1.0; text-halo-fill: rgba(255,255,255,0.6); text-placement: line; text-dy: -10; } ...


0

MapBox Studio creates and edits CartoCSS style-sheets, and mapnik uses their own SLD xml styles. Here is a small info about CartoCSS https://github.com/mapbox/carto Magic actually happened in this line: carto project.mml > mapnik.xml If you still can't get output form mapnik, run renderd with -f option, which will bring it in foreground and you will ...



Top 50 recent answers are included