New answers tagged

0

It depends on the data in the graph file. In order to include or exclude road types modify the osm2po.config file. See this thread. It's a similar question for bike routing But dont use maxSpeedOverrides anymore, it's deprecated in newer versions of osm2po.


3

Indeed, the default.config is very strict and to be honest it's too strict for my taste. I stumbled across a similar question weeks ago and modified the osm2po release notes for 5.1.0 to report this issue. Your solution above is correct. But I think there are not so many more positive tags, It would be shorter to modify the deny-option instead to sth. like ...


4

Ok, I am sorry about me answering my own question. I guess I had to ask the question to think about it more and be able resolve the problem. It turns out the problem was not in the OSM data but with the osm2po default config file I use to generate the graph. The problem Somewhere (line 188, if you are using osm2po 5.1.8) in the default config file, there ...


0

I have uncommented the following line which redirects the sql to stdout; #postp.pipeOut = true Now the issue resolved after I commented the line or can make the parameter to false.


2

Since you mentioned using QGIS, I had a similar problem, so I developed a QGIS plugin which is now available in the official QGIS plugins repository and can be found in the QGIS menu: Plugins / Manage and Install Plugins... and search for Disconnected Islands. http://plugins.qgis.org/plugins/disconnected-islands/ This plugin runs on a polyline layer, ...


0

Have a closer look into the screenshot you posted yourself. The checkbox points to a table called hh_2po_4pgr. This might be your edge-table. If so, the the_geom column is geom_way. Also check has_reverse_cost, otherwise oneways will be ignored.


0

Solved! It looks like there have been a few updates to the plugin since the example was made. The problem was with the edge_table and geometry fields. Edge table is the table containing the routing network, and geometry is the specific geometry table with the table. Hope that helps someone else.


1

Have a look at your database either in PGAdmin or through the QGIS Browser panel and check to see what your tables are named vs. what the example states. My 'edge_table' is called 'ways' my 'id' is called 'gid'



Top 50 recent answers are included