Tag Info

Hot answers tagged

3

Assuming you have an ASCII XYZ file with SRTM-like data loaded to the canvas: go to Raster -> Projections -> Warp (Reproject) select your input file (if not alredy selected) Unfortunately, gdalwarp can not write XYZ raster files, so we use a vrt file for intermediate saving select an output file test.vrt (format .vrt) Set Source SRS to EPSG:4326 ...


2

This is odd, but by following exactly your workflow I get this as a result: Gdalinfo with statistics for my version of resized-mercator.tif is here: Corner Coordinates: Upper Left ( -556597.454, 6621293.723) ( 5d 0' 0.00"W, 51d 0' 0.00"N) Lower Left ( -556597.454, 5011872.466) ( 5d 0' 0.00"W, 40d59'48.55"N) Upper Right ( 1113920.713, 6621293.723) ( ...


2

You could just set up a filter list in your CR selection parameter. cr_parameter.parameterType = 'Required' cr_parameter.direction = 'Input' cr_parameter.datatype = 'GPString' cr_parameter.filter.list = ["WGS 1984", "NAD 1983 NSRS2007 StatePlane California V FIPS 0405 (US Feet)", ...


2

There is a function to reproject geometry: ST_Transform( geom Geometry , newSRID Integer ) : Geometry List of functions can be found here. Note that in case you would want to rewrite existing geometry in Geometry column with reprojected data (instead of creating new table), you will need to update geometry_columns table and enter new SRID (in srid ...


2

The problem is that the data was never in UTM to begin with, and so by having a UTM projection, the file was ultimately being told to be something it wasn't. (Such is life) :) Reprojecting it doesn't fix the problem, because the transformation math is based on coordinates that don't match the assigned projection. To fix this I deleted the .prj file, and ...


1

On the fly transform: Click the CRS status button on the lower right corner of the window. Tick the "Enable 'on the fly' CRS transformation" dialogue box. Select your desired projection and click Apply. Result: Reproject layer: Right click on layer -> "Save as..." -> CRS: Selected CRS -> Then select your CRS from the list. I recommend on the fly ...


1

To figure out which file has a problematic projection and get additional clues about how to fix it, you can plot the maps on an ArcGIS basemap. This will get the shapefiles to appear on the same screen so you can see which is problematic. In this case you can quickly see that the SourceA file is plotted off in the Atlantic Ocean far from it's proper ...


1

If your raster file has proper CRS information, you can leave out the source SRS. Sometimes (especially if you have towgs84 datum shifts), it is necessary to set the source SRS different from what is stored inside the file. And some raster files (like jpg and png) do not have any SRS information, but you might now they are in degrees, so set EPSG:4326 for ...


1

Ok, in the end I was able to assign a new projection in ArcGIS. Using the data as specified above. I still dont understand what the problem was in QGIS. Possibly the libproj library was broken.


1

I guess your data uses US National Atlas Equal Area, EPSG:2163: +proj=laea +lat_0=45 +lon_0=-100 +x_0=0 +y_0=0 +a=6370997 +b=6370997 +units=m +no_defs Note that lon_0 is negative for western longitudes. and datum=none is no official definition.


1

I agree that the data is offsetted, but it is not a constant offset. I compared it with Openstreetmap boundaries from https://osm.wno-edv-service.de/boundaries/ in blue: The Vienna borders are off to the North, but the state border to the east is almost correct. So there is not much more that you can do with the data than delete it. Take the borders from ...


1

I was actually trying to do the same thing except with the OH south state plane grid and I came across your question. I was getting wrong results with 3735, now I get correct results with 3729. I expect if you change from 3734 to 3728, you will get the correct results. EPSG:3728: NAD83(NSRS2007) / Ohio North (ftUS) EPSG:3729: NAD83(NSRS2007) / Ohio South ...



Only top voted, non community-wiki answers of a minimum length are eligible