New answers tagged

1

Transform the point to the coordinate system of the raster. Make the point into a SpatialPointsDataFrame in the lat-long coordinate system: > e <- data.frame(x=148.1, y=-35.6, id=1) > coordinates(e)=~x+y > projection(e)=CRS("+init=epsg:4326") then transform to the coordinates of the raster: > et = spTransform(e,projection(r)) > plot(r)...


1

Before you do anything else, go Settings -> Options -> click the 'CRS' tab and set the default CRS to EPSG:27700 (British National Grid). You have two problems. Firstly, from the coordinate you circled in red in your illustration it's obvious that QGIS does not recognise that your OS Street View tiles are georeferenced. To fix this, from the 'georeferencing ...


0

Thank's a lot @xunilk ! I change the coordinates of the points I want in my layer with a QgsCoordinateTransform instance and now it works ! Here is the way I did (you cans translate the comments if you don't understand what i'm doing...): # On commence par creer une liste des points qgis delimitant la zone de chantier points = [] # On ajoute maintenant ...


0

You need to use QgsCoordinateReferenceSystem and QgsCoordinateTransform classes. I tried out next code to transform polygon vector layer of next image from EPSG: 32612 to EPSG: 4326. layer = iface.activeLayer() crsSrc = QgsCoordinateReferenceSystem(32612) crsDest = QgsCoordinateReferenceSystem(4326) xform = QgsCoordinateTransform(crsSrc, crsDest) ...


2

That is a trivial task with gdal: ogr2ogr -t_srs EPSG:3857 destination.shp source.shp See http://www.gdal.org/ogr2ogr.html for more information. There might be ruby bindings for this, I have no idea. EPSG:3857 coordinates are not lat/long though, if you really need those, just use EPSG:4326.


1

Project tool has Vertical parameter since 10.4. The link also mentions that you need to install additional package with coordinate system data.



Top 50 recent answers are included