Tag Info

New answers tagged

0

See this answer and this example. I hope this helps.


1

I'm not sure exactly how your geojson is formed, but the style argument in L.geoJson allows you to set styles for each feature. From this example: L.geoJson(states, { style: function(feature) { switch (feature.properties.party) { case 'Republican': return {color: "#ff0000"}; case 'Democrat': return {color: ...


2

function getStyle(feature, resolution){ var style; if (feature.get('field_6') === '4') style = new ol.style.Style({ image: new ol.style.Circle({ radius: 6, fill: new ol.style.Fill({ color: 'rgba(20,150,200,0.6)' }), stroke: new ol.style.Stroke({ ...


0

From QGIS just installed - styles do not work properly: This solved my problem: updated matplotlib using terminal reinstalled QGIS 2.8 Wien instead of QGIS 2.10 (http://www.kyngchaos.com/software/qgis)


1

After your edit, here's a suggestion. Stop using QML and switch to SLD. When you save the SLD from QGIS, it doesn't contain the labeling (at least not in v 2.7.2). SLD is an open standard by OGC based on XML schema. See the SLD spec here. Just create your style as before but export to SLD and you can edit in Notepad (using the SLD reference). I advocate ...


2

You can do this using a style function (see also the OL3 Example on Earthquake Clusters for a more detailed example of a style function - or search this site!). In your case, partial code would be along the lines of: var myStyleFunction = function(feature, resolution){ var field_1 = feature.get('field_1'); if (field_1 == "PENYEDIA AKOMODASI"){ ...


2

I can confirm this issue http://hub.qgis.org/issues/13162 with Pisa 2.10.1 on Yosemite 10.10.4. The best option right now would be to downgrade to 2.8. Projects with geotiffs that have styled in QGis 2.8 still shows correct in 2.10.1. (When I try to load the same geotiff with 2.10.1, I'm unable to style them.)


0

MapBox Studio creates and edits CartoCSS style-sheets, and mapnik uses their own SLD xml styles. Here is a small info about CartoCSS https://github.com/mapbox/carto Magic actually happened in this line: carto project.mml > mapnik.xml If you still can't get output form mapnik, run renderd with -f option, which will bring it in foreground and you will ...


2

Change the style of the vector and make the border the same colour, possibly a bit thicker too. That should mask it. I'm guessing that it isn't a real gap.


1

It's now set via the data defined button next to the symbols angle property. Just click that button and choose your field you want to bind the rotation to.



Top 50 recent answers are included