Tag Info

New answers tagged

1

Topology means "the rules and behaviors that model how points, lines, and polygons share coincident geometry." (Source.) These rules can apply specifically to geometry and how it is stored, or be created by you to check for certain things. Topology Checker looks at rules you have set up or chosen to apply to the data. Things like a line must be inside a ...


3

Instead of remove dangles you can correct the original layer. Use v.clean like Joseph says but run the tool v.clean.snap on your original borders layer, set the tollerance (for borders I think you can use a big value but you have to try) and then try again to dissolve. You can find eventualy remaining dangles using Topology Checker and "Must not have ...


2

You could try using the GRASS function v.clean and selecting the rmdangle which aims to remove any annoying dangles. You could access this from the Processing Toolbox. You can set the "threshold" option which determines what dangles can be deleted: The rmdangle tool deletes a dangle if the (combined) length is shorter than thresh or thresh < 0. If ...


1

The Integrate tool will fix small gaps in the data, but be very very very careful when using this tool on SDE data it will overwrite the existing features in the dataset with no undo. To use this tool properly: Backup your SDE data: either as XML workspace document, Geodatabase feature class (file or personal - use copy/paste), Shapefile or your current ...


0

The topology extension has to be CREATEd separately: CREATE EXTENSION postgis_topology; As to why also your raster functions fail: could you verify you are trying to use a version of PostGIS with raster support compiled in? (see http://www.postgis.net/docs/RT_FAQ.html#idp61635392)


1

Figured it out, and it had to do with my understanding of the shapefile format. I was not aware that each feature has their own seperate boundaries. I used to think that one edge can be shared by two adjacent polygons. To have both lines/vertices move at the same time all you have to do is enable topological editing in the snapping options.


1

I don't think this is a bug as currently, you're selecting to move the vertex of the left polygon which is similar to reshaping it: With the Node Tool, first select a node from the right polygon so that the Node tool knows which vertices belong to it. Then move the same vertex as before: There shouldn't be a gap anymore, instead you would be ...



Top 50 recent answers are included