New answers tagged

1

You need to consider to migrate your data to a spatial database, like Postgis. Shapefile is not a supported format for WFS-T. Check here for more information.


2

I'm afraid this is a very well known bug for which we have no solution at the moment: https://osgeo-org.atlassian.net/browse/GEOS-4773


0

In principle WFS 2.0 implies compliance to WFS 2.0.n it doesn't imply WFS 2.0.0, so you might need to check more closely that the servers you found that say they are compliant to WFS 2.0 aren't actually compliant to 2.0.2 That said, if you look at the OGC list of Implementations by Specification You can see that only one product appears to be implementing ...


3

You are using WFS 1.0.0. That WFS version is using Filter Encoding Standard 1.0.0 http://portal.opengeospatial.org/files/?artifact_id=1171 and there is indeed a typo in the standard. On page 17 the schema for filter capabilities is defined as: Spatial capabilities are encoded according to the following XML Schema fragment: <xsd:complexType ...


6

Try with intersects: <ogc:Intersects> ... </ogc:Intersects>


1

I can recreate this response from a local GeoServer but only when I send a connection request to a GeoServer that doesn't have a user of the name requested. When I have set up a user then it works exactly as I expect. With regards to @Dani's comment I don't get a FeatureStore which is expected as the WFSStore doesn't support writes when you use version ...


1

Yes, I think accessing the WMS or WFS services of the Nationaal Georegister is the way to go. Just for reference, here is the link to the WMS service: https://geodata.nationaalgeoregister.nl/napinfo/wms? I had no trouble accessing it in QGIS, and using the Identify button, I could access the true NAP data for points. Your question is not so much about ...


0

No 'Access-Control-Allow-Origin' header is present Well, there's your problem. You need to enable CORS on GeoServer. CORS is somewhat tricky, and enabling it will depend on your installation of GeoServer, and any HTTP proxies you might be running.


0

Alright, problem solved. I'd installed a package called geoserver-geonode. A security "feature" of the package makes it so only layers uploaded through GeoNode can be served up. Since I imported the JSON file through GeoServer's import extension, it was not allowed to be served. So I installed GeoServer and GeoNode packages separately and all is fine. (I ...


1

From the capabilities request the service supports versions 1.0 and 1.1 so simply request a lower WFS version and GML and use the GeoServer WPS as you want to.


1

This how PyWPS (versions 3 and 4) deals with this kind of request: Uses the service URL passed as argument to fetch whatever data is served. Creates a file in the disk with whatever data was retrieved. Provides your process with a pointer to the file. In case the data retrieved is GML 3.2, you then need something to help you read it. For that you have ...


3

Ok, if you're getting the 'No 'Access-Control-Allow-Origin' header is present' you have two options: Enable CORS Enable JSONP. Personally, I'd enable both. JSONP can be enabled with an environment variable, by the way, which makes it nice and easy. On Linux you can do this: export ENABLE_JSONP=true And then start Tomcat. For enabling CORS using ...



Top 50 recent answers are included