165 reputation
6
bio website
location
age
visits member for 2 years, 10 months
seen Feb 21 at 22:31

Apr
25
awarded  Popular Question
Mar
6
awarded  Popular Question
Aug
15
accepted Does PostGIS not work with psql?
Aug
15
comment Does PostGIS not work with psql?
Ah, you were correct. My problem was that my script was creating the database and then trying to create the tables from the same database. I had to separate the script into two parts. The first script connects to psql via the postgres database and then builds the PostGIS database. The second script connects to psql via the newly created database and then creates all the tables, etc. Sorry for my confusion, and I appreciate your help.
Aug
12
comment Does PostGIS not work with psql?
@Mapperz - I'm not sure what you mean. It looks like your link shows that Geography does exist.
Aug
12
asked Does PostGIS not work with psql?
Aug
10
comment PostGIS Error: type “geography” does not exist
@celenius - I'm pretty sure that was my problem. According to this blog and a couple other sources I looked at, they say Geography was just added in PostGIS 1.5.
Aug
9
comment PostGIS Error: type “geography” does not exist
Okay, I uninstalled the 64-bit version and tried it with the 32 and that included the PostGIS extension in Stack Builder. Finally! Thanks for your help!
Aug
9
accepted PostGIS Error: type “geography” does not exist
Aug
9
comment PostGIS Error: type “geography” does not exist
Thank you for the advice. I didn't want to use the "Postgres Plus" proprietary version, but it seemed like what they were recommending on the Postgres website and I got tricked into it. I uninstalled what I had and installed the version you linked. That all went fine, but Stack Builder is not showing PostGIS or the "Spatial Extensions" option it should be under. I don't know why it's not included in this...
Aug
9
comment PostGIS Error: type “geography” does not exist
Thanks for the link. Based on that, I think my problem is that I installed PostGIS 1.4, which doesn't support Geography. I can't figure out how to install PostGIS 1.5 though. When I download the Windows 1-click installer from the Postgres website it only seems to come with PostGIS 1.4. I can download 1.5 binaries from the PostGIS website, but I can't figure out how to install them.
Aug
9
awarded  Supporter
Aug
9
asked PostGIS Error: type “geography” does not exist
Jun
22
awarded  Scholar
Jun
22
accepted Casting a Geography type in PostGIS
Jun
22
comment Casting a Geography type in PostGIS
Ah, yes you are right about all of that. ST_ContainsProperly only works for Geometry, so I switched to using ST_Covers instead, which does what I want. I wanted to avoid casting to Geometry if it's not necessary. Here is the code I ended up with that works: SELECT ST_Covers(boundary, ST_GeographyFromText('Point(2 2)')) FROM source_imagery
Jun
22
awarded  Editor
Jun
22
revised Casting a Geography type in PostGIS
deleted 65 characters in body
Jun
22
awarded  Student
Jun
22
asked Casting a Geography type in PostGIS