369 reputation
117
bio website
location Germany
age
visits member for 2 years, 10 months
seen Jul 14 at 10:21

Apr
19
comment Why does a raster in Gauß-Krüger has a little offset to a shape in UTM?
Thanks again, Mintx and mkennedy. I added the resulting code to the question.
Apr
18
comment Why does a raster in Gauß-Krüger has a little offset to a shape in UTM?
Thanks. I don't have ArcGis/ArcMap, only ArcEngine. Are the 'Data Frame Properties' the properties of the raster layer or of the .mxd project file? Or something else?
Oct
10
comment How to edit the position of a banner text's pointer?
Thanks. So ICallout is the name I was looking for :)
Oct
9
comment Why does ITopologicalOperator2 .ConstructUnion produce a somehow invalid polygon?
@Petr: I added the spatial reference - no change. I think of making a test project I could share. Would that help?
Oct
8
comment Why does ITopologicalOperator2 .ConstructUnion produce a somehow invalid polygon?
@AHigh: The GraphicsContainer is a casted IActiveView.FocusMap (added to question). Casting resultPolygon to an IPolygon didn't help.
Oct
8
comment Why does ITopologicalOperator2 .ConstructUnion produce a somehow invalid polygon?
Thanks. I added it to both my source and the question. Unfortunately it didn't help with the problem.
Oct
2
comment Why does ITopologicalOperator2 .ConstructUnion produce a somehow invalid polygon?
@Petr, do you mean without using ConstructUnion? When I directly assign element.Geometry = feature.Shape it does work, as I pointed out. (made that more clear in the question) That's why I think it has to be something with ConstructUnion.
Oct
2
comment Why does ITopologicalOperator2 .ConstructUnion produce a somehow invalid polygon?
Thanks for the hints. 1.) I changed the asignment to ShapeCopy, but with no result. 2. + 3.) For testing I use a single layer where I select three polygon features. 4.) For testing I directly used the resultPolygon instead of the Buffer output as element geometry, but it didn't helped. And 5.) resultPolygon.IsEmpty is false.
Oct
2
comment Why does ITopologicalOperator2 .ConstructUnion produce a somehow invalid polygon?
@AHigh: Yes, I do make sure that there is only one geometry type. Thanks for pointing it out.
Oct
1
comment Geometry from multiple selected features into one geometry
I had to set the SpatialReference on the GeometryBag before adding elements. Otherwise the ConstructUnion would fail.
Apr
20
comment How to use ITrackCancel to escape IRubberBand track?
Unfortunatly I haven't found a solution yet.
Apr
19
comment How to use ITrackCancel to escape IRubberBand track?
Thanks Petr, I wasn't quite sure, because it isn't a real answer.
Apr
19
comment How to use ITrackCancel to escape IRubberBand track?
Using NewLineFeedback definitly works. I hook up the tools OnKeyDown event to escape on Escape. Anyways, the problem wasn't with ITrackCancel at all, see my question update 3.
Apr
19
comment How to use ITrackCancel to escape IRubberBand track?
Yes Kirk, but it didn't work either.
Apr
19
comment How to use ITrackCancel to escape IRubberBand track?
Thanks, Petr. I will try the display feedback. Btw. your display feedback link seems wrong. I guess you meant to link to IDisplayFeedback.
Apr
17
comment How to use ITrackCancel to escape IRubberBand track?
My Tool is for AX_MapControl and AX_PageLayoutControl so I tried your code with my IHookHelper instead of your IMxDocument but it didn't work. m_hookHelper.ActiveView.ScreenDisplay.CancelTracker is null. So it seems to be different somehow.
Mar
23
comment How to save and load elements to/from a layer in correct z-order?
Sorry, I can't see what the Envelope should help me with that? Can you give more detail please?
Mar
23
comment How to save and load elements to/from a layer in correct z-order?
Kirk: Good tip. I didn't know they are in the correct order. But still there is a glitch somewhere (see Update).
Jan
31
comment What is the best way of refreshing the view after drawing graphics?
Thanks, it works. I didn't know I could use Invalidate() with unchached layers. See my update for implementation details.
Jan
31
comment What is the best way of refreshing the view after drawing graphics?
@iterationx I tested all values, but only esriViewAll worked for me.