2

I have been trying to install my own CartoDB server for a few weeks.

I succeeded to install each part with no error (after few corrections) with this tutorial. Make check with CartoDB-SQL-API and Windshaft-CartoDB are ok!

I can import data : when I am in my dashboard, I can see my file with its 193 rows.

But when I try to see the table, the message "Error loading rows, check your SQL query" appears. All columns of my file are here but empty.

I try to click on Map View, which give me the following error : "There is a problem with your connection".

The view is already focused on the area which contains my data.

migrated from stackoverflow.com Jun 5 '14 at 11:41

This question came from our site for professional and enthusiast programmers.

  • I have the same problem, did you find a solution ? – G.T. Jun 12 '14 at 13:21
2

I faced this issue while forgotting to change the variable module.exports.node_host in my development environment file from '127.0.0.1' to 'development.localhost.lan'.

I am not using the service from the server itself (localhost), so this was preventing the CartoDBSqlApi work correctly.

0
+100

Following setting should fix this problem.

change tiler_port, sql_port in your app_config.yml to"8181", "8080" respectively.

tiler_port:    "8181"
sql_port:     "8080"

And host in windshaft and module.exports.node_host in sql-api config files to empty.

host: ‘’

module.exports.node_host: ‘’ // so the tiler and sql api listens to all IP address

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.