1

I'm using MapInfo 10.5 to read geographic data from PostGIS 1.5.2. After a pg_dump/pg_restore to another PostGIS-database on another server I'm trying the same via a VPN-tunnel. When I open a table I get the message "Map objects cannot be edited" and then I can't edit the geometries. The other attribute data is editable.

I've tried to create my database and tables both by hand and with easyloader with the same result. At the same time when I restore the database on my local computer I only get the message for one of the tables.

Any idea what could causing this problem?

Regards Ulrik

1

Probably a privileges issue. You should have a look on that post, or directly that one.

Another interesting way to go would be that one!

Hope it helps!

  • 1
    Thanks for your advises, the problem was i silly mistake from me installing the newest ODBC-Drive (9.0) for PostgreSQL which MapInfo doesn't support. With the 8.3.4 ODBC-drive everything works OK. – Ulrik Nilsson May 26 '11 at 9:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.