I installed GeoServer 2.1 RC1. It installed successfully, but when i click on WFS in services category, i got the following message.

Oops, something went wrong... Sorry, something unexpected happened on the server.

Here's an error report you can include in a JIRA bug report about this issue:

org.apache.wicket.WicketRuntimeException: Can't instantiate page using constructor public org.geoserver.wfs.web.WFSAdminPage() at org.apache.wicket.session.DefaultPageFactory.createPage(DefaultPageFactory.java:212) at org.apache.wicket.session.DefaultPageFactory.newPage(DefaultPageFactory.java:57) at org.apache.wicket.request.target.component.BookmarkablePageRequestTarget.newPage(BookmarkablePageRequestTarget.java:298) at org.apache.wicket.request.target.component.BookmarkablePageRequestTarget.getPage(BookmarkablePageRequestTarget.java:320) at org.apache.wicket.request.target.component.BookmarkablePageRequestTarget.processEvents(BookmarkablePageRequestTarget.java:234) at org.apache.wicket.request.AbstractRequestCycleProcessor.processEvents(AbstractRequestCycleProcessor.java:92) at org.apache.wicket.RequestCycle.processEventsAndRespond(RequestCycle.java:1250)

What is wrong ? How can i fix this problem ?

  • 7
    You're unlikely to get any answers after asking 17 questions, getting 30 answers, and accepting none of them. It might be worth asking this on the GeoServer forum. May 20, 2011 at 13:18
  • 1
    plus you'll need more details, such as how did you install it? which servlet container are you using? etc.
    – Ian Turton
    May 20, 2011 at 18:26
  • Can shared Marketplace return what is it’s problem can I fix it/
    – Gill Babeu
    Nov 23, 2018 at 10:38
  • This does not provide an answer to the question. Once you have sufficient reputation you will be able to comment on any post; instead, provide answers that don't require clarification from the asker. - From Review
    – BERA
    Nov 23, 2018 at 11:38
  • If you have a new question, please ask it by clicking the Ask Question button. Include a link to this question if it helps provide context. - From Review
    – Erik
    Nov 23, 2018 at 12:01

2 Answers 2


I got this same error on the latest stable version. I found that my wfs.xml file had become empty somehow.


I had a similar problem and found it was memory related; increasing the Java heap space fixed it for me. In C:\Program Files\GeoServer 2.1.0\wrapper\wrapper.conf I increased wrapper.java.maxmemory=128 to 512. Maybe that helps!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.