5

I'm going through the Alaska sample data tutorial for QGIS 2.2.0. Some of the lake labels appear and disappear at different scales when zooming. At 1:314,460 Becharof is visible, but Lower Ugashik doesn't appear until 1:157,230. It seems like others have had similar problems.

I have played with the rendering and placement dialogs to no avail. Even if I don't have the "magic combination" of parameters set, shouldn't they all behave the same?

For my needs, this may well render (no pun intended) the program useless. I need it to print labels when I need them!

2
  • Would you be able to edit your Question to include links to support your assertion that "It seems like others have had similar problems", please?
    – PolyGeo
    Jun 8, 2014 at 2:35
  • @polygeo, I googled this problem (qgis+disappearing+labels+zoom) or somesuch and found a number of similar problems (I think on here also). I did not document the sources. Dakcarto answered the question about the labeling bug being addressed in upcoming version 2.4.
    – CallMeChaz
    Jun 14, 2014 at 15:19

1 Answer 1

6

Try turning OFF geometry simplification for the layer in the Layer Properties dialog:

enter image description here

This (actually an issue with resultant invalid geometries being unlabelled) has been fixed, and will be included in upcoming 2.4 release (within a month).

5
  • 1
    Related issues on the QGIS tracker: hub.qgis.org/issues/9655, hub.qgis.org/issues/9673
    – dakcarto
    Jun 8, 2014 at 2:41
  • thanks for the response. I unchecked "simplify geom" to no avail. I believe the other parameters are properly selected to always display the lake labels. I have no options checked under LABELS > RENDERING other than "show all labels...". I don't think there is anything that would override this selection that would kill label output? Some lakes keep their labels when zooming, but Lower Ugashik comes and goes. I will anxiously await the new version.
    – CallMeChaz
    Jun 14, 2014 at 15:29
  • do I understand correctly that the lake may not be labeled due to geometry errors? I ran what I believe is the proper process to correct any errors on the layer, but none showed up. I wonder if other are seeing the same error with the Alsaka sample data? Is it perhaps something else?
    – CallMeChaz
    Jun 14, 2014 at 16:07
  • Well, a polygon will be clipped to the visible map extent prior to being labelled (unless using 'whole' polygon for centroid labeling). If the polygon has a complex perimeter, e.g. shoreline, then the extent clipping may create an invalid, but render-able polygon, i.e. not labeled, though. In upcoming 2.4, there are routines to try and fix such polygons on-the-fly, allowing for more labels to be shown.
    – dakcarto
    Jun 16, 2014 at 18:30
  • This is still a problem in 3.14.1. The labels appeared after unchecking simplify geometry
    – BERA
    Aug 19, 2020 at 17:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.