I have generated DEMs (bare earth) from Lidar data. For computational reasons, I have processed via ArcGis the lidar files in chunks, so I came up with different single DEMs.

After, I used "Mosaic to New Raster" tool, and created a single DEM raster.

I noticed that there are some gaps (lines) along the junctions between the original single DEM rasters (from which I got the single huge raster).

I tried this function in the raster calculator:

Con(IsNull("raster"), FocalStatistics("raster", NbrRectangle(5,5, "CELL"), "MEAN"), "raster")

where "raster" is the name of the single huge DEM.

The problem is that the gaps are still there. Any suggestion?

  • 1
    Could you upload a screenshot showing the problem areas?
    – Aaron
    Jun 13, 2014 at 16:30

2 Answers 2


I support the answer by radouxju, but would like to add:

As you have chosen to do this in chunks (good idea! you can process multiple chunks simultaneously) I recommend using an overlap of ~1k with your tiles.

You have not elaborated on how you create the DEM from LiDAR data but lets assume that you are using LiDAR->MultiPoint->Terrain->Raster DEM workflow or the new LAS Dataset to Raster tool. Both of these methods employ triangulation to fill in the blanks where there are no returns like water areas and points that don't match ground class (2 and 8). At the ephemera the triangulation becomes more erratic and will lead to mismatches over void areas.

With a ~1k overlap the triangulation is pinned down by the other side of the void, then trim the tiles back to 1/2 the overlap to get rid of the dodgy data. Guaranteed no gaps!

I would (and do) start with a grid/AOI and subdivide it to make the areas of processing to ensure that everything is covered and nothing is missed. Before exporting the raster look at the snap raster environment setting - this will ensure that the tiles' cell edges line up and resampling is not performed during the mosaic - which would slow it down and hurt your accuracy.

  • Hello! Thanks for the reply. I circumvent the problem creating a unique DEM (bare earth) with a different approach. While previously the procedure 'Las to multiploint' and then interpolation of point elevation via 'Natural Neghibor' was too computer-intensive for my PC, I then used 'Las dataset to Raster'(resources.arcgis.com/en/help/main/10.1/index.html#//…). So, I got a unique DEM, of manageable size (it depends on the output cell size; by the way, I used a value equal to the average Lidar dataset's point density). Thanks. Any further suggestion/comment is welcome.
    – NewAtGis
    Jun 12, 2014 at 11:50
  • Yes, that's a great tool.. new at 10.1 I believe. Prior to that you had to LAS->MultiPoint->Terrain->Raster and that was very intensive. You can still do it in blocks, but trust me on the overlaps. I do this A LOT and have learned about that particular pitfall the hard way. Jun 12, 2014 at 21:46
  • 1
    +1 It is important to incorporate good data management prior to running analysis, including setting overlaps.
    – Aaron
    Jun 13, 2014 at 16:22

A good thing to do would be to create your chunks with a predefined extent that is snapped to your mosaic and that covers the entire area (see the environment settings of your tools).

For your correcting patch, maybe you should make sure that the "DATA" option is used for focalstat, but this is normally the default. On the other hand, I would start checking with the identity tool to see if your gaps are really NoData.

  • Thanks. Do you mean that the option "ignore no data" in hte focal stat tool must be checked or unchecked? Besides, since I am using the focal stat command from within the Raster Calculator, what the correct statement would be to check/uncheck that option right into the Raster Calculator's formula?
    – NewAtGis
    Jun 10, 2014 at 12:16
  • ignore NoData should be true. Try with FocalStatistics("raster", NbrRectangle(5,5, "CELL"), "MEAN", "True")
    – radouxju
    Jun 10, 2014 at 12:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.