2

I am using ArcGIS 10.2, ArcMap and I have a shapefile point layer in which I can't select any points. (I'm having the same problem this person describes but none of the suggested solutions work: Why is select by drawing a rectangle not working in ArcGIS?)

To simplify things, I have removed all other layers from the map. I have highlighted the layer in the table of contents. I have also done: right-click > Selection > 'Make this the only selectable layer in the table'. I have tried lasso, rectangle, polygon, with no luck. When I add a polygon layer to the map, I'm able to select polygons with these tools. I also added a different point layer to the map and was able to select those points. But there's something about this point layer. It's in GCS_WGS_1984, not that that should have anything to do with it (also the polygon layer that I can select is in in GCS_WGS_1984 too).

Any additional suggestions?

  • 1
    How was the point file created? Run the Check Geometry Tool. if your point file has no geometry issues, output table will be empty. If there are issues, run the repair geometry tool – Nxaunxau Jun 10 '14 at 14:14
  • 3
    Could you try adding the layer to a fresh MXD? – GISKid Jun 10 '14 at 14:21
  • Geometry checked fine. – L T Jun 10 '14 at 15:04
  • Creating a fresh map worked. Though we have no idea why. The 'keep it simple, stupid' method worked again! – L T Jun 10 '14 at 15:05
  • If you try to select points with a rectangle: are the points selected (highlighted) in the attribute table? – Jens Jun 10 '14 at 15:15
1

This sounds like it could be one of many things. One thought though is to go into the settings of your interactive selection settings menu in the MXD (Selection > Interactive Selection Method) and within that sub-menu make sure the correct option is selected, you'd most likely want Create New Selection. If that got changed it could be actually working correctly by not selecting anything, if for example it was set to remove from current selection, then every time you try and select features it would be trying to unselect those features.

Also, again, I don't know if this is your particular problem or not, but you may want to go to Selection > Selection Options and make sure the the settings there make sense for your use case. One thing of particular note I think for you would be, if your points are actually multi-point features, then you definitely need to check that it is set to select features partially or completely within the box or graphic. If you don't have this set correctly and it's multi-point features, you may be having issues because not all of the points for each feature are within the selection area.

I know these aren't the only two possible causes by any means, and from the steps you say you took checking with other datasets I doubt these are it, but, as I don't know the specifics of your situation, it doesn't hurt to try anyway.

Definitely listen to the two comments on your question though, do run the check geometry tool and, if necessary, the repair geometry. Also, do try viewing it in another MXD; and I do not mean dragging/copying the layer from your current MXD and dragging/pasting it into a new MXD, I mean actually opening a new MXD and going to add data and adding the data from source.

Also, if none of this works, just for testing purposes at least, try converting/exporting the dataset in question to a different format and test it there (ex: if it is currently a shapefile, export to a FileGDB feature class, if it is a FileGDB feature class, export to a shapefile. This way you can at least tell if it is a problem with the data it self, or if it is a problem with just that file.

  • thank you for your suggestions. I double-checked all the things you mentioned before I tried making a new map. The selection settings were already set to 'Create new selection' and 'select features partially or completely within the box or graphic'. So it's a mystery why a new map worked. But thank you for your thorough and rapid response! – L T Jun 10 '14 at 15:07
  • @LT If in doubt, when it comes to ESRI, always try a new MXD. For some reason MXD's become corrupted over time... don't know why, but if it should be working and isn't, it may very well be a corrupted MXD. – John Jun 10 '14 at 18:11
0

Same thing happened to me and it was because the shapefile was joined to an excel table. It seems like the "Select by Location" tool does not work over a shapefile that has a join. once I removed the join, the selection tool worked as expected.

  • 1
    It probably wasn't the join itself which caused the problem (it is definitely possible to select a point feature with a join) but possibly in your case it was caused by corruption in the joined Excel table – Stephen Lead Jan 7 '15 at 23:29
0

I'm sure this was solved already one way or the other, but I was having the same problem. I imported an XY Event layer and was unable to select any of the points from that layer. The data was all there and the points located correctly, so it was a puzzler.

My solution was to reproject the new XY layer into the coordinate system being used in the current map. That solved it for me.

0

Same thing happened to me, and the same solution worked. I am in ArcMap 10.3.1 and both running Select by Location in a model in Model Builder, and running a Select by Location manually would only select some of the features that fell within the parameters.

Closing ArcMap and reopening did the trick!

  • Your answer worked. I created a new shapefile with about 50 points, and the only selection tool that would work was "select by rectangle." I played with a bunch of settings, and nothing else worked. I closed and reopened arcmap and select by polygon now works on the shapefile that it didn't work on before. – Josh W Feb 7 '17 at 3:38

protected by PolyGeo Feb 7 '17 at 4:20

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.