2

I am currently working on an intensive project that requires me to edit the fields of literally thousands of line segments. While updating the shapefile, it crashed on me. Today, qgis has probably crashed on me upwards of five times now. Originally, I thought it was just my computer but now it's happened to one of my group members. I tried opening the project file and re-adding a slightly older version of the file, but qgis crashed once more when I tried to look at the attribute table to see any saved changes.

Both of us are running qgis 2.2 on mac laptops. The crashing happened in the version of qgis before this one, which is why I upgraded. I thought that maybe there was a bug that had been addressed in the latest version.

Has anyone else ran into this issue of editing large files and being unable to open their shapefiles' attribute tables without crashing? Does anyone know any way around this issue?

Thanks

1

I had the same problem.

It was a bug in QGIS Browser 2.2 (https://hub.qgis.org/issues/10461)

It was apparently solved (https://github.com/qgis/QGIS/commit/2f6e6ca060ebeb8e84bafaa0ce4c7ab875ddf2a1)

  • Please do not leave link only answers. Take some time to expand on the answer further. – Brad Nesom Apr 13 '15 at 16:22
0

Are you certain the shapefile is valid? The way I would tackle this would be to first check its validity. You can do this using ogr2ogr and convert the shapefile to a new shapefile to see if this completes succesfully, e.g:

ogr2ogr -skipfailures -f "ESRI Shapefile"  new_shapefile.shp old_shapefile.shp

You can read more about ogr2ogr here and download it here

There is also another question which may be related about corrupt shapefiles

  • I don't know what you mean by asking if the shapefile is valid? I can't think of any reason why the shapefile would have become corrupted. I did not edit the file in excel when I had it open in qgis nor did I save anything when I closed the program before trying to look at the attribute table in qgis again. I will try using the ogr2ogr that you've provided. Thank you. – user32297 Jun 12 '14 at 14:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.