0

I am getting an error message when atempting to create a connection in ArcCatalog (I'm working under the 10.0 version). The message is : Failed to Connect to the specified server. No ArcSDE server licence found. Then I Check the Service esri_sde and it has not started, so I try to start it then I get this error message : The ArcSde Service(esri_sde) service on Local Computer started and then stopped. Some services stop automatically if they have no work to do. I've tried deleting the service then creating it all over again, checked the registry, launched CCleaner.. Rebooted the computer, still the same error When I check the log files, I got this in the giomgr_esri_sde.log :

Sat Jun 14 16:15:23 2014 - ** Spatial Database I/O Manager ** Sat Jun 14 16:15:23 2014 - SDE System Startup Initiated . . . Sat Jun 14 16:15:23 2014 - Validated System Paths. Sat Jun 14 16:15:23 2014 - SDE IOMGR going into background . . . Sat Jun 14 16:15:23 2014 - System Parameter table 'SERVER_CONFIG' Read. Sat Jun 14 16:15:24 2014 - Initialized Shared Memory Segment. Sat Jun 14 16:15:24 2014 - Error (-327), No ArcSDE server license found.

And in the sde_esri_sde.log :


ArcSDE 10.0 for PostgreSQL Build 685 Fri May 14 12:05:43 2010

Connected to instance . . . DBMS Connection established...

Error (-327), No ArcSDE server license found.

I don't understand this licence problem! I have already registered and I do have the licence. What could be wrong ?

  • 1
    Did you install the keycode within the PostgreSQL instance? If you don't have an AUTH_KEY row in the sde.sde_server_config table, ArcSDE will not function. – Vince Jun 14 '14 at 21:24
2

Ah that would explain your previous post. Regardless of configuration / port numbers nothing is going to happen if SDE does not start.

It sounds like you have fallen into the same traps I did when I first installed SDE... in the end I ended up removing Postgres and SDE and reinstalling with a better understanding of the process.

I am also using PostGIS for PostgreSQL and the pg_geometry storage, if you are doing the same ensure your version of PostGIS is comparable. And while we're talking about versions don't install any other version of PostgreSQL than is supplied on the ESRI install disc I suspect that the installer has special settings for ESRI and even if you have the same version downloaded it will not work with SDE.

Embedding the server key is done during the post-install where the ArcGis Server key is embedded somewhere in the database, not sure where, if you suspect that it has failed or you have not completed it successfully then you can re-run it.

If you have chosen to call your database anything other than sde then you're going to have a problem... the post-install is setup to initialize a database called sde and if it's called something else you need to edit some settings in postgresql using sdeservice:

from the command line:

sdeservice -o modify -r ADMIN_DATABASE -v DBname -d postgresql -i service_name -p user

to update/reset the ArcGis server key using sdesetup:

sdesetup -o update_key -d POSTGRESQL -u admin_user -p password -D DBname -l license_file

substitute your own values for DBname, admin_user, password, service_name...

Seriously though, why bother with the service? Direct connection works without a lot of fiddling around. You still need to check that postgres is running, look for postgres.exe and pg_ctrl in the task manager, if they're not there then there is serious issues with your database; Postgres will start and then stop immediately if there is nothing to do, which would indicate that there are serious issues with the database.

  • No, there is nothing special about the installer that ships with ArcSDE. I've had no difficulty using the latest-greatest PG build when working with ArcGIS 10.1 & 10.2, but PG has improved over that time as well (e.g., no more major changes in minor releases which break compatibility). – Vince Jun 14 '14 at 22:48
  • I experienced issues with trying to install SDE on an existing PostgreSQL/PostGIS installation, the version number was the same.. to be fair though I knew very little about it at the time and may have given up where perseverance may have been needed. – Michael Stimson Jun 14 '14 at 22:56
  • PG 8.3.8 was kinda quirky, but I always compiled my own binaries from source on Linux. – Vince Jun 15 '14 at 0:53
  • @MichaelMiles-Stimson thank you again for ur response. I have re-installed the whole software and actually I've already removed PostGIS just in case.. Now the service has started. – GeoSal Jun 16 '14 at 19:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.