1

I’ve previously been successful in importing ecw into QGIS 2.0 but the same methods (for example Adding *.ecw files to QGIS on Windows) have failed with a fresh install of QGIS 2.2 with OSGeo4W on W7 64. Seems to be a GDAL version issue. The OSGeo4W shell tells me I have GDAL version 1.11 but this new installed QGIS is “compiled against GDAL/OGR" version 1.10 according to 'about'. I’ve successfully got the ecw format listed by ‘gdalinfo –formats’ but that’s version 1.11 which I assume QGIS 2.2 can’t see. I note that OSGeo4W64/bin has both gdal110.dll and gdal111.dll.

How do I force QGIS to use gdal 1.11 and not 1.10 and so be able to read ecw rasters (which I assume is the problem)?


I find that I have a different folder structure from my fresh QGIS2.2 install from OSGeo4W which has no less than 50 gdal files (from “gdal_auth.bat” to “gdalwarp.exe”) in C:/OSGeoW64/bin and one file “gdal_ECW_JP2ECW.dll” which is in C:/OSGeoW64/bin/gdalplugins. No “gisinternals” folder exists for me. I have followed the instructions on the GDAL website and also other answers on gis.stackexchange by manually copying the various ERDAS_ecw_SDKfiles to the appropriate folders. This worked with QGIS2.0 but fails with QGIS2.2. I've put C:/OSGeo4W/bin as the path in the Gdal Tools executables dialog box but QGIS2.2 still fails to recognise ecw rasters.


Success! QGIS2.2 64bit now importing all my ecws perfectly. @AndreJ's advice to manually roll back the default Gdal1.11 to Gdal1.10 and reinstall using the OSGeo4W advanced options works. Either OSGeo4W should default to Gdal1.10 on express install or QGIS should compile against Gdal1.11.

0

1 Answer 1

4

If QGIS is compiled against GDAL 1.10, you can't do much about it. So you have to downgrade the ecw driver to 1.10 to make them work together.

See also these tickets:

The issue might be solved with QGIS 2.4, which is just around the corner.

In the setup.exe of OSGEO4W64, select Advanced install, later change the view from Category to full.

Look for the gdal-ecw package , and the version number in front of it. It might be 1.11.0. If you click on Keep, you can toggle to the 1.10.1 version. This should run with your QGIS version compiled against GDAL 1.10.

Other opportunity is to use the 32bit version of QGIS 2.2. It runs well on 64bit machines. The standalone version has the ecw driver by default, with the correct GDAL version 1.10.1.

By the way, I have not installed any ERDAS SDK package. This seems to be unnecessary for Windows. And no need to set any paths manually. The qgis.bat launched when clicking on the QGIS icon sets all required paths.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.