I downloaded the OS Terrain 50 dataset in ascii format, then unzipped all the folders and searched for all *.asc files. I then copied and pasted these into a new folder, so that they could be easily located when geoprocessing.

I then used the "Mosaic to new raster tool" in ArcMap 10.2 and selected all the asciis as the input rasters, saved to a new geodatabase, defined projection (BNG), pixel type (32 bit float) and number of bands (1) to match the original files. I left everything else as default options.

The resulting image has large areas missing in the south east of England (see below). When you zoom in beyond 1:750,000 the gaps disappear. Another strange thing is that when I removed the layer from the table of contents, then re-added it the whole dataset now only shows when zoomed in beyond 1:1,500,000 (and gaps still until 1:750,000).

I don't desperately need to show the data at national scale, however just curious as to what might be wrong and whether anyone can help. Thanks, Sarah

enter image description here


1 Answer 1


The "Mosaic to new raster tool" tool is and always has been flaky. (Search ESRI forums and you will find many posts with similar issues) Although this problem seems to be fairly common, i don't know of a definitive solution/workaround.

I had some success with NOT saving the result to a geodatabase but rather a folder location and outputting to ESRI Grid file type instead.

It seems, however I wasn't able to confirm this, that the tool works better if you mosaic the input data type to the same output data type. Thus it should also work if you first import all 50 of your tiles into a geodatabase then run mosaic to new raster outputting to the same location in that same geodatabase.

This "workaround", if you can call it that, does not work all the time and sometimes I end up splitting up the input rasters to several groups and I mosaic those separately then again to final results. I also had some success with ensuring all input rasters had the same spatial reference and mosaicing to an output of that same spatial reference. Similarly, if spatial reference was missing, not specifying an output spatial reference also worked a few times.

Sorry, not elegant.

  • That worked saving the output to a folder first and then importing into a gdb. Didn't need to try the other techniques but good to know in case it ever happens again! Thanks
    – user32476
    Jun 17, 2014 at 10:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.