1

I try to use QGIS to display some data stored in PostGIS, some of the schemas don't show except public; and it's a testing database, so I have only one super user: postgres. I use PostgreSQL9.3.

Anyone has some suggestion?

4
  • 1
    Which schemas do you not see you are expecting to see? Does it have a table that has a geometry column?
    – Regina Obe
    Jun 16, 2014 at 18:57
  • I found the reason, it's because other schema is empty or there's no vector data inside. Previous I load a raster data into a schema named scratch, once I added a vector data, it shows in QGIS.
    – Allen Song
    Jun 16, 2014 at 19:12
  • 3
    @Allen, please move your "comment" above to an "answer" below and, once StakExchange allows you (I think after 2 days), you can mark your answer as "Accepted" (hit the checkmark next to the answer) to close out this question. Thanks. Jun 16, 2014 at 19:30
  • It doesn't allow me to move this answer to below because i ask the question and answer the question within a certain time.
    – Allen Song
    Jun 16, 2014 at 19:58

2 Answers 2

1

I found the reason, it's because other schema is empty or there's no vector data inside. Previous I load a raster data into a schema named scratch

0

If you create a new database connection, you can check Only look in schema public, or leave it unchecked.

You can change this later if you edit the connection (unless there are no other schemas, then the entry is greyed out).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.