1

I am trying to create ArcGIS desktop add-in using Visual Studio Professional 2012. But when I use ArcGIS Snippets Finder to insert code, I found the applicable versions as follows:

' Applicable ArcGIS Product Versions: ' 9.2 ' 9.3 ' 9.3.1 ' 10.0

But I am using ArcGIS 10.2.1, and the ArcObjects obtained from ArcGIS 10.2.1 Desktop installation CD.

I want to know where can get the snippets applicable for ArcGIS 10.2.1 (or above). And what version of Visual Studio can support ArcObjects for 10.2.1?

  • 4
    All code snippets for version 10.0 should work in 10.2.1. I'm using VS 2013 with 10.2.1, and I've used 2012 with it too. – pvdev Jun 19 '14 at 8:41
  • 2
    Officially, 10.2.x works with VS 2010 and VS 2012. – kenbuja Jun 19 '14 at 13:08
1

As commented by @kenbuja the ArcObjects SDK system requirements for ArcGIS 10.2.x say that:

Supported Visual Studio versions include

  • Microsoft Visual Studio 2010 (C++) Professional, Premium, Ultimate Edition (with or without Service Pack 1).
  • Microsoft Visual Studio 2012 (C#, VB.NET) Professional, Premium, Ultimate Edition.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.