1

I have problems to visualize ecw files for qgis 2.3.0 using ubuntu 12.04 LTS. From terminal, following the instructions for qgis 1.8 found at ECW for QGIS 1.8 in Ubuntu 12.04, because launching the command sudo gdal-ecw-build /usr/local/. I added the repository ppa:ubuntugis/ubuntugis-unstable and then did these steps:

wget http://de-mirror.org/gentoo/distfiles/libecwj2-3.3-2006-09-06.zip
unzip libecwj2-3.3-2006-09-06.zip
cd libecwj2-3.3
./configure
make
sudo make install
sudo gdal-ecw-build /usr/local/ 

Launching the last command I receive some warnings like this:

ecwdataset.cpp:1501:15: warning: deprecated conversion from string constant to ‘char*’ [-Wwrite-strings]

and then an error message:

/usr/local/include/gdal_priv.h:225:19: error: ‘char**
GDALOpenInfo::papszSiblingFiles’ is private
ecwdataset.cpp:2526:48: error: within this context

Finally (in Italian because I have an Italian version of Ubuntu 12.04 LTS):

make: *** [ecwdataset.o] Errore 1

Can anybody help me?

15
  • Try up-to-date instructions e.g. gis.stackexchange.com/questions/94917/…
    – underdark
    Jun 19, 2014 at 15:46
  • A better instruction would be at gis.stackexchange.com/questions/94870/…. You have probably GDAL 1.11 installed, but the libgdal-ecw package is only compiled for GDAL 1.10. I found a workaround for that.
    – AndreJ
    Jun 19, 2014 at 16:50
  • Can you add the repositories and the steps you did, and the error message you got? You can still edit your question for that.
    – AndreJ
    Jun 19, 2014 at 17:42
  • thanks Andre I added the errors and warnings.Yes, I added the repository suggested ( ppa:ubuntugis/ubuntugis-unstable). How can I check the GDAL version installed on my system? Jun 20, 2014 at 8:36
  • gdalinfo --version reports the gdal version. You used the old 3.3 SDK, while I was successful with the 5.1 SDK (no configure and make for that, but no write access on ecw files). I got some wanrings too, but not that error. Maybe your GDAL is too new for the SDK.
    – AndreJ
    Jun 20, 2014 at 8:47

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.