0

I'm currently trying to produce a line-of-sight map of a tower with no results. Every time I run the viewshed tool, the program uses the base Z value of the DEM.

I use the DEM Raster for the elevation model. The point has a Z value in the attribute table of 100.9. Which is the AGL height in meters. I leave the Z factor at 1.

For some reason the viewshed is not the line-of-sight from 100.9M but from the base Z value. Anyone have any ideas what I am doing wrong?

I have been out of this game for about 5 years. I learned the program back in the 9.1 days. So I could have easily forgotten a step or two.

  • 1
    Are the points actually 3D or do they just have a z value attribute? What is the name of the attribute? Have you reviewed the current help files on the specific tool(s) you are trying to use and the Visibility Toolset in general? Some field names are used automatically and in a particular order of priority. Related/duplicate: gis.stackexchange.com/questions/102581/… – Chris W Jun 24 '14 at 21:02
  • They are a 3D point however I added a Z value via the 3D tool. I have no idea how to add the Z value to the original 3D XYZ. Yes, I have used the help files, but its all in python. And yes the Visibility Toolset – user32798 Jun 24 '14 at 21:24
  • Sorry, I think I might be getting confused because you mention line of sight (one tool) and viewshed (a different tool). I believe the Viewshed tool only takes xy from the observer features and z is determined from the surface. If you want to raise the observer point, you need to use a Z factor when you run the tool, which is the height of your tower - it's not read automatically, though it might be if your field names are appropriate per this help page. – Chris W Jun 24 '14 at 21:40
  • Well I also tried the line-of-sight tool and it does the same thing.I've construed a line-of-sight from the tower to a test point. However, the tool still runs it across the ground. I've changed the Z-Facter on the viewshed tool and it still has the exact same results. – user32798 Jun 24 '14 at 21:47
  • Could you post a screenshot of your tool dialog box, attribute table for the point, and resulting viewshed output raster? – Chris W Jun 24 '14 at 21:54
2

based on your table, the field name for the height above ground should be modified : it has to be OFFSETA . Z is not recognized as an elevation value by the tools.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.