2

I followed this post, the first answer, to clip a USGS Quad in order to remove the borders so that I can tile them. Basically it utilized the lat/long at the corners in a .txt file to import a rectangle using "add delimited text layer". I then reproject the rectangle to match the CRS of the USGS quad. After I clip it I get black edges, see image.

black corners

I offered the error as a comment in the aforementioned post and it was answered that its likely from re-projecting the rectangle and that I should use -dstalpha or -dstnodata to make it white. When I use those two options, I just get a colored rectangle. I actually want that area transparent for when I tile multiple USGS Quad maps. I even tried to re-project the quad map to the CRS of the rectangle.

Does anyone know how I can clip the USGS quad without having the black corners for tiling pruposes? FYI... I am using QGIS 2.2 on Windows 7.

EDIT:

The mask that I have compiled using the delimited text layer matches the area that I would like to clip perfectly. So I dont think that I have an error. I downloaded the Newburgh and the Cornwall on Hudson Quads. Reading the corner coordinates I developed the following two .txt files:

Newburgh

Nr;WKT 1;POLYGON((-74.00 41.5, -74.125 41.5, -74.125 41.625, -74.00 41.625, -74.00 41.5))

Cornwall on Hudson

Nr;WKT 1;POLYGON((-74.00 41.375, -74.125 41.375, -74.125 41.5, -74.00 41.5, -74.00 41.375))

1

The source map comes with paletted colours, but only 12 are used.

So I have set the nodata value to 255 in the clipper dialogue, and the nodata areas are not black, nor are the black parts set to nodata:

enter image description here

If you intend to combine the rasters to a vrt, it is better to expand them to rgba (but only after you applied the nodata value).

  • Awesome, Andre to the rescue again. – LandArch Jun 26 '14 at 15:33
1

If you have a polygon that represents the area you can use that as a Mask in QGIS. If you do not, you can create a polygon of the area you want. You could also type the coordinates into the Clipper tool in QGIS to ensure you do not clip into the black area (this will require you to analyze your quad to ensure you are using the best coordinates). Another option would be to not clip the rasters, but rather create a VRT (Virtual Rater) of all the rasters you want to mosaic. With a VRT you can identify a No Data value, which will ignore the black values.

  • This worked, but only with the already clipped raster images. The only problem with this is all black values in the raster are removed, not just the black edges. – LandArch Jun 26 '14 at 9:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.