2

I'm trying to dissolve some low-level polygons, but the result I'm getting has lots of little pieces of lines left floating around in the output polygons. I've tried doing "repair geometry" on both the input featureclass (before dissolving) and on the output featureclass (after dissolve) and neither fixes the problem.

Any thoughts?

[Edit: Also: dissolve running without errors, oddly.]

Dissolve issue image

  • have you tried running dissolve on your dissolved layer? – Maksim Jun 25 '14 at 18:35
  • The problem is most likely unclean topology in the original data, as Branco mentions. There are two main approaches to fixing - clean up the topology in the original data (Integrate comes to mind), or eliminate the slivers created in the resulting data. Some solutions (available at other questions here on GIS.SE) can work on either end. – Chris W Jun 25 '14 at 21:52
3

It might be possible that the topology is off a bit and there are tiny little gaps in between your polygons.

If that is the case, a discussion entitled Polygon - Dissolve; leaves "cracks" in the polygon feature may be pretty helpful.

Try zooming in very, very close to see if you see anything. Add a fill color to the polygons to help make gaps easier to see.

  • There are! You're the (wo?)man -- thank you so much for this. – nick_eu Jun 25 '14 at 18:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.