1

I did an interpolation of soil pH using 232 data points in geostatistical analyst with IDW, RBF and ordinary kriging. For all 3 methods, the range of pH values change (become smaller) after I export the geostatistical layers to raster. I understand that has something to do with the way values are calculated per cell in raster, but is there a way I could keep the pH range in the output raster?

1

The conversion of a geostatistical model to a raster will discretize the support (creating pixels). The value of the pixels will be defined at their center, so if the maximum/minimum is not at the center of a pixel, it will not be stored in the raster. If you want to be closer to the values, you will need to take a smaller pixel size.

|improve this answer|||||
  • You can also use a different cells assignment type (e.g. MEAN or MAX or MIN or RANGE) -- this will only be the statistics per cell, however, not per raster. – Erica Jun 27 '14 at 15:36
  • I see @radouxju. unfortunately my resolution can't be better because of my other datasets :( – user32922 Jun 27 '14 at 16:40
  • @Erica: do I change the cell assignment type under 'environment'? but what do u mean when u say the statistics is per cell (pixel?) not per raster? – user32922 Jun 27 '14 at 16:41
  • It's part of the Point to Raster tool options. This setting determines how the raster cell is assigned a value -- the default is "most common" (say, points of 5, 5, 10, the raster cell is then 5), or if it has two values (say, 5 and 10) it will randomly pick one. Using a different assignment type can give more control over how the values are assigned. Only way to ensure every point is represented is with smaller pixels, as @radouxju has said. – Erica Jun 27 '14 at 16:45
  • 1
    Ah ok, I understand that. but the geostatistical layer is not a shapefile with points, so how can I do the cell assignment? I don't find it in the 'environments' when I export it to raster. And I also tried reducing the output cell size when I exported the geostatistical layer to raster, but the range got even smaller actually. Am I doing something wrongly?? – user32922 Jun 28 '14 at 13:19
0

Try exporting your prediction as a vector using filled contours. Then convert the vector back to a raster layer using the polygon to raster tool.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.