1

This question already has an answer here:

Windows 7, OsGeo4W pack installed including QGIS 2.4.0 and GRASS.

In QGIS when I try to execute a GRASS geoprocessing algorithm I get this popup:

Missing dependency. This algorithm cannot be run :-( This algorithm requires GRASS GIS 7 to be run. Unfortunately, it seems that GRASS GIS 7 is not installed in your system, or it is not correctly configured to be used from QGIS Click here to know more about how to install and configure GRASS GIS 7 to be used with QGIS

The link doesn't help. I get the same message at my computer at work with QGIS 2.2.0

The GRASS plugins are activated under geoprocessing settings.

Do I need to configure something?

enter image description here

When I run MSYS I get this:

enter image description here

marked as duplicate by Andre Silva, xunilk, ArMoraer, aldo_tapia, whyzar Jan 5 '18 at 11:15

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Can you run GRASS independently? Also note that QGis 2.4 just been released yesterday and there might be initial issues – Curlew Jun 28 '14 at 11:08
  • What about if you try SAGA tools? I have posted on hub.qgis.org/issues/9671 - missing dependency when using Windows network user account. If I use local account all works fine. – Miro Jun 28 '14 at 14:46
  • Curlew: I cant run GRASS independently, it goes BEEP and i see a startup popup for 0,5 s. Miro: When i try SAGA from qgis i get the same error "Missing depen...." – BERA Jun 28 '14 at 16:49
  • your path Bj"rn or Björn is not correct (without space nor accent) – gene Jun 28 '14 at 17:33
  • Gene: i know, how do i change it? – BERA Jun 28 '14 at 17:55
3

MSYS stumbles upon the non-ACII characters of your Windows user name. Maybe GRASS fails on that too.

Try with a new user name without non-ASCII characters.

  • I uninstalled (=deleted whole Osgeo4w folder), made a new windows user without Ö and reinstalled Osgeo4w and now it works perfectly. It couldnt handle the swedish letter :) Thank you for the help! – BERA Jun 28 '14 at 19:23
1

If you look at the Processing Toolbox:

enter image description here

There are algoritithms for GRASS GIS 6.x (GRASS commands) and GRASS GIS 7 (GRASS GIS 7 commands).

Have you configured the path of GRASS 7 (Configuring external applications) ?

  • I dont know, have i? Look at screenshot above. Left one is GRASS command line. GRASS gui wont start – BERA Jun 28 '14 at 16:52

Not the answer you're looking for? Browse other questions tagged or ask your own question.