1

I'm trying to get the Zoom to Postcode plugin for QGIS to work on my machine (Mavericks, QGIS 2.2.0)

The plugin downloads fine, and when I first try to search for a postcode it alerts me that it needs to download the postcode data, which I approve.

The loading dialog box appears and seems to complete OK.

Has anyone else had this problem? Maybe I can download the file someplace else and manually include it.

2
  • Looking into the source code, I managed to find the download target and now have the downloaded .pkl files ready to go...I think I just need to find the right place to put them
    – Ben Mayo
    Jul 3, 2014 at 9:56
  • Ok - I found the location but sure enough the .pkl files are there and they all look good. Opened one up in a text editor and searched for the postcodes I'm trying with and they are there too - so I'm totally at a loss as to the problem.
    – Ben Mayo
    Jul 3, 2014 at 10:10

1 Answer 1

2

Solved it.

The path was wrong, as it was looking for a file 'directory\file' when it needed to look for 'directory/file'

If you're trying to use this plugin on a Mac, go to the plugin folder, and open zoomtopostcode.py in a plain text editor.

Change line 168 from

find_pkl = str("UK_Postcodes\\" + input_pcode[:2] + ".pkl")

to

find_pkl = str("UK_Postcodes//" + input_pcode[:2] + ".pkl")

Hopefully it will now work for you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.