When I try to use the nvis module in Grass, QGis, pops-up a warning window saying "Module nviz not found". how can I solve this issue and use the nviz?

  • Which QGIS and GRASS versions are you using (or trying to use)? – Joseph Jul 3 '14 at 12:51
  • I am using QGis 2.2.0 Valmiera and the Grass plugin is version 0.1. – Rui Prata Jul 3 '14 at 13:15
  • Have you downloaded the Processing plugin and ran any GRASS functions via the Processing Toolbox? – Joseph Jul 3 '14 at 13:22
  • I just tried to use the processing toolbox but there is something wrong: the nviz does not recognize any raster files to use as elevation file even though I have the DEM/raster file opened in Qgis... it runs but it shows no result. – Rui Prata Jul 3 '14 at 13:41
  • Sorry, now it detected the raster DEM (I reopened it), it ran, but it still shows nothing at the end... do I have to open any nvis created file which was stored anywhere or something like this? – Rui Prata Jul 3 '14 at 13:45

I faced a very similar problem a while ago: Unable to load 'nviz' through GRASS

For me, downloading/installing WinGRASS-6.4.1 and running GRASS 6.4.1.exe seperately from QGIS worked. I was able to use nviz (after configuring the project location and mapsets etc).

I still can't run it through QGIS for some reason but seems to work perfectly if I run it on its own.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.