1

I copied a small bit of text from a word document into a label which had the ' ← ' symbol in it (2190, alt+x).

Whenever I export the map to a pdf, the '←' symbol becomes a spiral. If I make the arrow symbol bold, it becomes a fleur de lis in the pdf. I have tried checking the 'Embed All Document Fonts', 'Convert Marker Symbols to Ploygons', changed all the Picture Symbol settings and nothing seems to keep the arrow from becoming something else.

It does not appear to matter if the text is a label taken from the attribute table, a Label Expression or is an annotation as the end result is the same.

Where did my arrow go? aka wicked awesome fleur de lis

If I save the word document as a .pdf, the arrow remains an arrow and does not change. Additionally, if the text with the spiral/fleur de lis is copied from the map pdf and pasted into Notepad, the spiral reverts to an arrow.

I realize there are many, many workarounds to this problem (not using the arrow, inserting a symbol etc), but I am more curious as to why it only seems to happen in ArcMap. It is now a matter of stubbornly trying to keep the arrow from being converted by ArcMap as a matter of principle.

Does anyone have any insight on why this occurs / how to keep the arrow?

Solution

By using

"<FNT name = 'Arial'>" +  ' ←' + "</FNT>" + ' Pathway to Moosehide Village '  

it came out fine. Thanks for all the suggestions.

  • Do you get the same problem if you export to image (.jpg, .tif...etc)? – artwork21 Jul 8 '14 at 18:23
  • 1
    The rendering engine for PDF is not the most current now that Adobe has gone to "software as a service" or maybe before. All I know is I've heard complaints that they don't play as nice as they used to. BTW - You could use a text based work around of <-- and --> on either end of each label. – user23715 Jul 8 '14 at 18:25
  • No problems exporting to formats other than .pdf – Adam Thom Jul 8 '14 at 18:40
  • 1
    What font are you using? Can it be embedded? I note this KB article which states that not all fonts can be embedded (I've run into this before) or are actually valid fonts. It's possible that the pdf creator built into Arc won't do it, but the one Word has access to will. Have you tried printing to pdf as opposed to exporting? – Chris W Jul 8 '14 at 19:03
  • 1
    I literally just tried changing the font to Arial, and it exports correctly. I am using Palatino Linotype, which I have a feeling is the root of the issue. – Adam Thom Jul 8 '14 at 19:04
3

By using

"<FNT name = 'Arial'>" +  ' ←' + "</FNT>" + ' Pathway to Moosehide Village '  

it came out fine and kept the original font. Thanks for all the suggestions.

0

While I'm unsure why this is occurring (my best guess is some font capability issue), if you add graphic text (in the Drawing toolbar) on top of your map in the Layout View and export to pdf -the arrow stays. I just tested this myself. I hope this helps!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.