7

I have a huge problem displaying the austrian Basemap.at WMTS Service in QGIS 2.4. When I add the service, qgis logs multiple errors on failed tile requests. When I zoom into the map, it is displayed in a very poor quality (see screenshot).
I really don't know how to fix this problem - can anyone tell me how to increase the quality of the tiles?

WMTS URL: http://maps.wien.gv.at/basemap/1.0.0/WMTSCapabilities.xml Basemap.at Scrennshot: Poor Quality

UPDATE 1:
I tried setting the resampling methods in QGIS to Cubic/Average, as you guys advised me to and compared the result with the same zoomlevel in ArcGIS. In this screenshot you can see the result: At the same scale level QGIS just skips an entire tile level, whereas arcgis loads this level correctly. - Any other ideas? enter image description here

  • can you add the URL of the service so we can try it ourselves? – Ian Turton Jul 9 '14 at 10:29
  • Of course: Here you are: maps.wien.gv.at/basemap/1.0.0/WMTSCapabilities.xml – root676 Jul 9 '14 at 10:31
  • You mean you want labels for towns, cities etc (eg. "Leising") to constantly appear in a larger font when you zoom in as they did before you applied the Cubic/Average resampling? – Joseph Jul 9 '14 at 11:46
  • Yes, and for example the label of the road L2091 just doesn't show up. – root676 Jul 9 '14 at 11:57
  • Other than changing the Zoomed out option from Average and back to Nearest neighbour, I'm not sure how to maintain clarity for both the map and its corresponding labels. Perhaps others may offer advice. – Joseph Jul 9 '14 at 12:13
8

After some experiments I found out that the core of this problem is related to the predefined scale levels QGIS uses. Through the slider provided at View > Panels > Tile Scales I could gather more information about the WMTS-Scale Levels the Basemap.at WMTS scales at. As a next step i went to Settings > Options > Map Tools and replaced the scales which are defined as default with the Basemap.at scale-values through the following XML-code:

    <qgsScales version="1.0">
      <scale value="1:591657550"/>
      <scale value="1:295828775"/>
      <scale value="1:73957193"/>
      <scale value="1:36978596"/>
      <scale value="1:18489298"/>
      <scale value="1:9244649"/>
      <scale value="1:4622324"/>
      <scale value="1:2311162"/>
      <scale value="1:1155581"/>
      <scale value="1:577790"/>
      <scale value="1:288896"/>
      <scale value="1:144448"/>
      <scale value="1:72224"/>
      <scale value="1:36112"/>
      <scale value="1:18056"/>
      <scale value="1:9028"/>
      <scale value="1:4514"/>
      <scale value="1:2256"/>
    </qgsScales>

When you now reload the map, the quality of the map will be outstanding!

  • The Tile MapScale Plugin does the same as you found out manually. – AndreJ Sep 12 '14 at 9:53
  • Yes indeed, but the plugin turns out to be rather buggy with this WMTS-Service. I tried it and at least for me it doesn't work well... – root676 Sep 12 '14 at 10:35
5

You could play around with the Resampling options in Layer Properties > Style > Resampling. I did a quick test and got the map to be a bit sharper by applying the following changes:

enter image description here

enter image description here

  • 1
    Your resampling suggestion works well for me. But I have to open the Layer Properties and set the resampling to Cubic every time I open the layer from Browser Panel > Tile Server (XYZ). Is there any way to set the cubic resampling as the default whenever the layer is loaded? – Stu Smith Jul 21 '17 at 22:23
  • @StuSmith - I think you should ask this a new question as I'm not too sure :) – Joseph Jul 31 '17 at 9:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.