0

While adding multiple raster and vector layers (and setting them all in CRS WGS84) in QGIS 2.2, they don't seem to overlap. Interestingly enough, only raster files overlap between each other, the same for vector layers. My 'on the fly' projection is included.

As a "hint", raster layers coordinates are 6 or 7 digit numbers, while it's 2-digit numbers for vector layers (area in central Italy). Also to mention is that I'm completely new to GIS so every answer is good enough. Thanks

  • 1
    welcme to gis SE. What do you mean with 6 digit number ? If it is more than 180 degree, it cannot be WGS84. So you probably should try and find the correct CRS. If you give some examples of the coordinates (+ approximate location) for your data, maybe someone here could help. – radouxju Jul 9 '14 at 15:40
  • Without knowing anything else, it sounds like your vector layers are just not as accurate as your raster layers. – Dan C Jul 9 '14 at 15:58
  • An example of the point on vector layer is (11.30,44.46), which I imagine is the actual longitude and latitude (in degrees). The same point on raster layer would be approximately (684140,4929886). All layer CRSs are set on WGS84 (EPSG:4326)! – rampion Jul 9 '14 at 16:06
  • The raster layers are UTM zone 32N. The GeoCRS (datum) could be ED50 or ETRS89 or Roma 1940 / Monte Mario. That's if the sample point is in Bologna. – mkennedy Jul 9 '14 at 23:21
  • Thanks everyone, especially mkennedy. The raster layer was UTM/32N and now it works perfectly. For the future, how will I know which is the GeoCRS of any downloaded data layer? – rampion Jul 11 '14 at 14:12
1

How did you do the setting them all in CRS WGS84? Using Set CRS for Layerhas definitely corrupted your data. This changes the CRS, but does not reproject the coordinates to the new CRS.

So delete those layers with 6digit coordinates, and add them again. Usually the CRS information is stored in the file, and should not be altered. As mkennedy noted, they can be in UTM 32N, based on WGS84, ED50 or ETRS89. On-the-fly-reprojection will make them fit to your lat/lon vector data.

If you intend to do any calculation or clipping on both data, you can Save As...the raster files to a different name and CRS. But NEVER use Set CRS for Layerfor that.

  • Thanks for valuable comments. The point is (as I answered to mkennedy above) that I had to import the raster layer at the start as UTM/32N, while I was forcing the WGS84 because I was told that's the correct one. – rampion Jul 11 '14 at 14:15
  • The forcing part is where you made the mistake. But I think most newbies do that. – AndreJ Jul 12 '14 at 7:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.