When moving or editing the annotation, the annotation disappears. We are editing on a black background, so the text isn't just blending in to the background. The attribute table does not show any abnormality, but the "Zoom to Selected" option is grayed out. It can be selected in the table, but does not display in the display window. Anyone have this problem? Found any solutions?

  • Alyssa D merged your duplicate account gis.stackexchange.com/users/2735/lyzi
    – Mapperz
    Jun 2 '11 at 20:52
  • I have a similar problem with editing points. When I move the point it just disappears. Still shows up in the attr table but gone from the map. An undo and re-try will often remedy the problem. I will try to get esri to duplicate as bug when I get a round tuit.
    – Brad Nesom
    Jun 2 '11 at 21:51
  • Alyssa, which software (and version) are you using? ArcGIS 10.0? Jun 2 '11 at 23:36
  • Yes, we are working in 10.
    – Alyssa D
    Jun 3 '11 at 0:01
  • 1
    @ Brad -- I had a similar problem today at work. I just installed the latest patch for ArcView 10 too. Is this the case at your end? - meaning did you just install the latest patch? I tried a few things, and I ultimately had to redo the symbology and add the point again for it to show up. It was very odd!! All I did is move the point slightly and it was gone. It was in the attribute table, I could select it, but I could not get it to show up without removing it then adding it again in the symbology options.
    – Dano
    Jun 3 '11 at 2:35

Just in case anybody else runs into this problem and lands on this page. Try:

-- Repair geometry -- Rebuild the spatial index (use the Add Spatial Index tool)

The latter worked for me when features in an Annotation Class were disappear upon zooming in.

Good luck,


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.