I have a set of shapefiles which I'm trying to open in MapInfo Professional 7.8. Each of the shapefiles has a .prj file which looks like this:


When I open these files I'm asked for a projection setting, I've tried the 'Latitude/Longitude (OSGB 36)', 'British National Grid' and a fair few others but always see an empty mapper window. If I try to look at the coordinates using MapInfo Professional's SQL query options then rather strangely I see blank values for CentroidX(obj),CentroidY(obj).

If I use the Universal Translator to convert one of the shapefiles to MID/MIF then I can see the coordinates, like this:

 CoordSys Earth Projection 8, 104, "m", -2, 49, 0.999601272, 400000, -100000                            
    ID decimal(5,0)
LINE 534061.554 182550.177 534062.547 182550.525
LINE 534062.547 182550.525 534064.181051453 182547.058664689
LINE 535691.843 183008.914 535693.182 183007.166
LINE 534840.184 182700.747 534839.889 182701.372
LINE 536273.212731382 183548.850943691 536271.824 183548.284
LINE 533330.033439369 182375.414376181 533329.876996451 182376.898647792

I need to be able to edit these files in MapInfo Professional and then need to convert them to WGS84 but am rather stuck. My question is how I can open these files so that I can see and edit the data?


UPDATE: Having taken James S's advice most of my files are now appearing in MapInfo, great, thanks James S! But I have a small set of files which didn't work and if I convert those to MID/MIF I see a different kind of coordinates, as follows. Note that the .prj file for these shapefiles appears to be exactly the same as that above. How can I deal with these ones?

CoordSys Earth Projection 8, 79, "m", -2, 49, 0.9996012717, 400000, -100000 Bounds (-7845061.1011,-15524202.1641) (8645061.1011,4470074.53373)                                                         
    ID0 char(21)
    NUMBER char(254)
    ID char(254)
    DESCRIPTIO char(254)
    STATUS char(15)
    TYPE char(9)
    DURATION char(10)
386065100 336732200
386062540 336736210
386061790 336737010
386058060 336739750
386057400 336740120
386054630 336741240
386054180 336741470
386050910 336743490
386050660 336743630

1 Answer 1


In the Projection dialog of universal translator, if you push the B key 3 or 4 times you should find the British National Grid projections. I cant remember what it will say in MapInfo 7.8 but its probably the top one you want. If you do that and convert it straight to MapInfo TAB format.

If this works, then you could do a Save File As..., and change the projection by pressing the Projection button and selecting WGS84. Then if you open the newly created file, it should be in WGS84

  • Great! That worked for most of my files, but I have some which look different so I added the details above. Thanks!
    – Elliveny
    Commented Jun 3, 2011 at 10:54
  • The coordinates have too many digits to appear in the correct place. They appear to have 9 digits rather than 6. This could be a problem with the units used in the original data (the data isn't in meters)?
    – James S
    Commented Jun 7, 2011 at 11:22
  • Thanks James. I found if I write code to process these files then finding and replacing the 9 digit numbers with the values divided by 1000 (e.g. replacing 336741240 with 336741.240) makes the files usable - which is great and gives me a way forward, but I just wonder if I can do this another way? Can I change the 'CoordSys Earth Projection' line so that the units are correct?
    – Elliveny
    Commented Jul 21, 2011 at 20:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.