2

I recently updated my Ubuntu system to version 14.04. I added the sources and installed QGIS as per the directions on the QGIS website. Everything looks good, except for I do not have all the available plugins listed that I do on my windows installation. I haven't been able to recreate it again in order to take a screen capture, but I received an error that there is not python support.

I have not been able to find much through we searches on the topic. So, does anyone know of a way to install Python support for QGIS Ubuntu? Or is this likely a bug related to 2.4's relative newness?

Update

A screenshot of errors on startupenter image description here

and a screenshot of the settings tab in the manage plugins UIenter image description here

4
  • The qgis site lists two ways to install on Ubuntu. The ubuntugis ppa and QGIS repository. Which did you use? I used ubuntugis and have no problems with python.
    – user2856
    Jul 11, 2014 at 22:38
  • I did it both ways with the same results.
    – LandArch
    Jul 12, 2014 at 1:19
  • might still be related to gis.stackexchange.com/questions/97950/…
    – underdark
    Jul 12, 2014 at 19:48
  • 1
    @underdark: ubuntugis has updated the relevant packages for trusty, so that issue is solved.
    – AndreJ
    Jul 13, 2014 at 5:51

1 Answer 1

2

It worked for me with a clean install of QGIS 2.2 from ubuntugis unstable, and update to QGIS 2.4.

If you tried both methods you might have mixed packages. Make sure you have removed all packages from the qgis.org site, and remove qgis.org from the sources list and/or the Software Center.

3
  • Did as you suggested and still the same. I have the same errors that are posted in my original post. I may have missed something, could you recommend a tutorial for what you suggested?
    – LandArch
    Jul 16, 2014 at 22:04
  • Here you may find some hints on cleaning your system: gis.stackexchange.com/questions/29094/…. Didn't you solve the problem then?
    – AndreJ
    Jul 18, 2014 at 15:54
  • Just another solutuion: package python-pyspatialite may cause errors: hub.qgis.org/issues/10099. Please have a look at the installation log if the problem remains.
    – AndreJ
    Jul 20, 2014 at 5:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.