2

I knew that FeatureToLine had issues with large datasets and I have seen other questions revolving around the same error, but I am completely baffled by this. Basically, this function works perfectly with few features (less than a couple hundred), but when a larger number (300+) is entered, it gives this error.

This is the offending function:

    add_print_message("Extracting all intersects as points...")
    arcpy.Intersect_analysis(feature_class, feature_class + "_inter", output_type="POINT")

    add_print_message("Splitting all lines at intersected points...")
    arcpy.SplitLineAtPoint_management(feature_class, feature_class + "_inter", feature_class + "_split")

    add_print_message("Repairing geometry...")
    arcpy.RepairGeometry_management(feature_class + "_split", "DELETE_NULL")

    add_print_message("Converting all split features to lines...")
    arcpy.FeatureToLine_management(feature_class + "_split", feature_class + "_ftl")

It seems to fail after FeatureToLine runs and it gives this error: "Invalid Topology [Feature not found on delete.]"

There are other questions regarding this error on gis.stackexchange but they are of little help.

I have tried Dice and the error still happens and/or Dice fails on chunks that the function utilizes perfectly. I have also tried running it in ArcCatalog but have the same issues.

Any ideas about what could be going wrong (I can't partition any smaller, although I guess I could subdivide, but that is a last resort for now)

  • It probably is an issue with the Feature To Line tool, but, just in case, maybe run check/repair geometry tool on the data, just to be sure it isn't a data issue. – John Jul 15 '14 at 18:26
  • I run Repair Geometry on the data before Feature To Line is ran. I have also gotten new data in case in the previous set was corrupted. I have run Check Geometry on the input for the tool and it comes out clean. – Madeline Jul 15 '14 at 18:27
  • Yea, see that now, sorry... I've never run into this myself or I'd offer to help more. Good luck. – John Jul 15 '14 at 18:32
1

I recommend working in a File Geodatabase and examining Shape_Length of feature_class + "_split". Sort Shape_length ascending, you may have zero length geometries from splitting lines very close to the start or end of the Line. As a test, delete the features that have 0 for shape_length and see if FeatureToLine finishes.

  • Hah. That worked. Thanks for the help! That hadn't even occurred to me to check! – Madeline Jul 15 '14 at 20:49
0

Not sure about your specific error, but if you are trying to split your input line FC where the features intersect, why not just return the output of the Intersection tool output as a line (output_type="LINE" or better yet output_type="INPUT")? I think you may be doing some gymnastics that are unneeded.

  • Thank you for your suggestion. I looked at it and it actually solves one issue but it doesn't really serve as a replacement for Feature To Line. I need Feature To Line to split partially overlapping features so I can do processing on them. Basically I need lines that completely overlap rather than only partially overlapping. I will look at it more to see if there is any way to use this rather than having to use multiple calls to tools. – Madeline Jul 15 '14 at 19:10
  • What are you doing with these completely overlapping line features? Are these road routes? – csny490 Jul 15 '14 at 20:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.